Sign up ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

I have tried to load firefox using command line command in Lubuntu 14.04. Firefox is loading, but not loading as expected.(used -fullscreen)

firefox -fullscreen

when I execute the command am also getting the below error

(process:7411): GLib-CRITICAL **: g_slice_set_config: assertion 'sys_page_size == 0' failed

please help to load firefox in fullscreen mode from command line.

share|improve this question

1 Answer 1

up vote 2 down vote accepted



Firefox doesn't have -fullscreen option

You can use xdotool and create a shell script as follows.

firefox & # one can use any url
sleep 5
xdotool key F11 # hit full screen
share|improve this answer
But am also getting the same error without -fullscreen – Senthil Jun 26 '14 at 7:19
That looks like just a warning. See I am assuming firefox starts up fine despite of the error shown. – Myth Jun 26 '14 at 7:28

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.