Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

First time running Ubuntu 11.04 and getting used to Unity, I decided to install proprietary drivers for my Nvidia graphic card. The output of lspci | grep VGA is:

00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09)
01:00.0 VGA compatible controller: nVidia Corporation Device 0df5 (rev a1)

If I activate the driver that is "recommended", next time I try to login in a Unity session it just changes to the classic. How can that be happening?

I attach the screenshoot of my proprietary driver screen:

enter image description here

share|improve this question
1  
It would appear that you have two graphics cards: an integrated Intel one and an Nvidia one... although I'm not positive considering that it simply calls the Nvidia board a 'device'. –  Nathan Osman Jun 15 '11 at 6:11
    
Yes I do have. But would that be the cause of the problem? –  Nobita Jun 15 '11 at 6:17
1  
You may also need to change BIOS settings for the NVidia card (e.g. to be displayed first). –  Takkat Jun 15 '11 at 6:54
    
Does the order of the output of that command means which one is used as default? –  Nobita Jun 15 '11 at 8:42
1  
This question has the best answers with optimus: askubuntu.com/questions/36930/… –  Jorge Castro Jun 21 '11 at 14:16
show 1 more comment

3 Answers 3

up vote 3 down vote accepted

Have a look at the bumblebee section in https://launchpad.net/~hybrid-graphics-linux

b) try bumblebee for simultaneously using the intel and nvidia cards:
sudo apt-get install git
# type password
git clone http://github.com/MrMEEE/bumblebee.git
cd bumblebee/
sudo ./install.sh
optirun glxgears
# check the speed and compare to running:
glxgears
# If you have google-chrome installed, you can try it with/without optirun and report the FPS values on the mailing list:
optirun google-chrome http://webglsamples.googlecode.com/hg/aquarium/aquarium.html
share|improve this answer
    
I configured it and it seems to work fine. Let's see when the automatic switching comes into action. –  Nobita Jun 22 '11 at 9:10
add comment

This happens because of the bad support for intel sandy bridge graphics driver, infact what you have is not a pure nVidia graphics driver, it's an intel graphics with nVidia optimus tecnology.

The nVidia drivers doesn't work for me too.

share|improve this answer
    
Have a look at the bumblebee section in launchpad.net/~hybrid-graphics-linux –  213441265152351 Jun 22 '11 at 9:52
add comment
sudo get-apt remove nvidia-common
sudo get-apt remove nvidia-current
sudo get-apt remove nvidia-settings
sudo get-apt install nvidia-common
sudo get-apt install nvidia-current
sudo get-apt install nvidia-settings

Reboot and activate the new driver.

share|improve this answer
1  
A more elegant way to do this with a single command is: sudo apt-get --reinstall install nvidia-common nvidia-current nvidia-settings –  Eliah Kagan Aug 24 '12 at 3:36
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.