Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

[I'm a beginner to Linux] Hi I installed Ubuntu 14.04 alongside Windows 8 following instructions in here - http://www.everydaylinuxuser.com/2013/09/install-ubuntu-linux-alongside-windows.html

Without much awareness of UEFI boot mode, I selected /dev/sda (not an EFI boot partition) for boot loader during the Ubuntu installation. I couldn't boot to Ubuntu, it always boots Windows 8.

Based on advice in the forums, booted using live CD and tried Boot repair.

Beginning with "Recommended repair", I tried several attempts still unable to fix anything.

Here are the key settings in the last attempt:

  • Associated boot partition with EFI option (which is in /dev/sda7)

  • Selected to use default EFI file name and to backup and rename Windows EFI file names.

  • Disabled SEcureboot

Like I said, no solution yet.

Here is the paste bin link http://paste.ubuntu.com/7703609/ Few things I noticed in this output (not sure if they are relevant)

  • Unusual EFI: Please report this message to boot.repair@gmail.com

  • WARNING: GPT (GUID Partition Table) detected on '/dev/sda'! The util fdisk doesn't support GPT. Use GNU Parted.

Should I try to do a clean reinstall selecting /dev/sda7 as bootloader? will it break Windows?

Thanks in advance!

share|improve this question
    
Can't you use Windows' bootloader to launch Ubuntu? There are threads on superuser.com how to configure Windows bootloaders. Just saying this because it may save you some trouble reinstalling and repartitioning your system. –  Jakke Jun 26 at 4:07
    
If you elect to reinstall, be sure you fully have backed up Windows. Many accidentally overwrite Windows. You must only use Something else if reinstalling. fdisk does not work on gpt drives, but for BIOS drives Boot-Repair runs it, you can ignore that error. It also reports the unusual EFI a lot. Not sure what it sees, but you show ubuntu entry in UEFI menu. From UEFI/BIOS can you choose ubuntu entry or using in one time boot key (often f12 but varies) to boot ubuntu? –  oldfred Jun 26 at 4:08

2 Answers 2

Based on your Boot Repair output, I'd say you should be booting fine. The fact that it's not working suggests you've got a flaky firmware. Therefore, I recommend you check your manufacturer for a firmware (they'll call it a "BIOS") update. If one is available, install it and try again.

If that doesn't work, try opening an Administrator command prompt in Windows and type the following:

bcdedit /set {bootmgr} path \EFI\ubuntu\shimx64.efi

This might get it working properly, but I can't make any promises about that.

If this fails, and if the computer is new enough, I recommend you return it to the store for a refund, since at this point the conclusion is that the firmware is so badly broken that the machine isn't fit for use, you shouldn't accept it, and the manufacturer has to be made forcefully aware of the problem.

If that's not an option, there are uglier workarounds, such as the backup-and-rename-files option on the Advanced tab of Boot Repair. I describe these in more detail with reference to rEFInd here. The details will vary if you're using GRUB, but the principles are the same.

share|improve this answer

@user297926

I did use the same link you used when I configured my laptop for dual boot. I am no Ubuntu expert, but I als used the following links to get my system working. I hope these will help you as much it help me.

Also can you describe your hardware. Google the computer hardware with the respective ubuntu installation. I my case I had to make a few modifications get the graphic driver to work properly.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.