Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm new to Ubuntu. In my system WIFI is working fine but Ethernet is not working fine.

ifconfig -a

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:13703 errors:0 dropped:0 overruns:0 frame:0
          TX packets:13703 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:1263769 (1.2 MB)  TX bytes:1263769 (1.2 MB)

wlan0     Link encap:Ethernet  HWaddr 0c:60:76:65:d7:c2  
          inet addr:10.67.110.56  Bcast:10.67.110.255  Mask:255.255.255.0
          inet6 addr: fe80::e60:76ff:fe65:d7c2/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:418816 errors:0 dropped:0 overruns:0 frame:464023
          TX packets:367793 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:544360588 (544.3 MB)  TX bytes:32354669 (32.3 MB)
          Interrupt:17 Base address:0xc000 

when I'm trying to get eth0 i am getting an message like

ifconfig etho

etho: error fetching interface information: Device not found" 

and I have done lspci | grep -i eth it returns nothing.

could you provide solutions for this?

share|improve this question

The fact that ifconfig -a does not list eth0 means that your wired adapter hasn't been found. Things to check:

  • lspci - is you network adapter listed?
  • Reboot and enter bios setup. Check if the built in network adapter is enabled.
share|improve this answer
    
Thank you for your valuable solutions. It's working Now :) – Rajiv Reddy Jun 26 '14 at 1:37

Also adding few points that has helped me solve similar problems alongside what @sMurf has replied to;

You can verify if the MAC address found on the device is same as that present in the /etc/udev/rules.d/*-persistent-net.rules

This is more relevant if you are making use of a VDI image in Virtual Box or the equivalent environment. If in Virtual Box environment, goto "Machine -> Settings -> Network" and verify that the MAC address' match. If they don't, then you can edit with the correct fields in the above mentioned file and restart the VM.

share|improve this answer

In my case I solved a problem where I had no wired ethernet (but wireless worked). I tried sudo dhclient and that did not fix the issue, at least right away. Next, I rebooted and toggled the 'Enable Onboard LAN' setting from the BIOS. Then wired ethernet worked again for me.

Note that to get into the BIOS, you'll need to press F2 or F10 or your system's specified key, and then in once in the BIOS you'll need to find the 'Onboard LAN' setting.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.