Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

To get started with juju, I installed it on a local machine(actually a xUbuntu VM running on windows).

juju-gui got deployed successfully. Then used the gui to deploy mysql.

But it's been hours and still juju status returns

environment: local
machines:
  "0":
    agent-state: started
    agent-version: 1.18.1.1
    dns-name: localhost
    instance-id: localhost
    series: trusty
  "1":
    agent-state: started
    agent-version: 1.18.1.1
    dns-name: 10.0.3.154
    instance-id: atech-local-machine-1
    series: trusty
    hardware: arch=i386
  "2":
    instance-id: pending
    series: precise
  "3":
    instance-id: pending
    series: precise
  "4":
    instance-id: pending
    series: precise
services:
  juju-gui:
    charm: cs:trusty/juju-gui-3
    exposed: true
    units:
      juju-gui/0:
        agent-state: started
        agent-version: 1.18.1.1
        machine: "1"
        open-ports:
        - 80/tcp
        - 443/tcp
        public-address: 10.0.3.154
  mysql:
    charm: cs:precise/mysql-46
    exposed: true
    relations:
      cluster:
      - mysql
    units:
      mysql/0:
        agent-state: pending
        machine: "4"

What went wrong?

My understanding is that it first installs a lxc and then mysql on it. How do I check whether the status of these?

Checked /var/log/juju/all-machines.log. There are quite number of errors. The most repeated one being machine-0:

2014-06-25 04:33:28 ERROR juju runner.go:220 worker: exited "environ-provisioner": failed to process updated machines: cannot start machine 2: no matching tools available

share|improve this question
    
checked /var/log/juju/all-machines.log. Is this the correct file to check? If yes, there are quite number of errors. The most repeated one being machine-0: 2014-06-25 04:33:28 ERROR juju runner.go:220 worker: exited "environ-provisioner": failed to process updated machines: cannot start machine 2: no matching tools available –  John Jun 25 at 5:22
    
You're currently running 1.18.1 when the latest stable release is 1.18.3. Try juju destroy-environment, upgrade juju on your machine, then bootstrapand deploy again. –  Marco Ceppi Jun 25 at 11:35
    
@MarcoCeppi how do I track what's happening? which are the logs to watch out for after a deploy command is executed. –  John Jun 26 at 18:15
    
The allmachines.log is correct, can you pastebin the entire log and edit it into your question? thanks! –  Jorge Castro Jul 1 at 18:00

1 Answer 1

It looks like you are trying to deploy a Precise charm on a Trusty host and because of that the correct version of the charm tools is not available. You will probably have better luck picking the Trusty version of the MySQL charm https://jujucharms.com/trusty/mysql-1/?text=mysql

share|improve this answer
    
I don't think this applies. Machine 0, the users machine, is trusty and can do both precise and trusty –  Marco Ceppi Jun 25 at 11:35

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.