Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I want to connect my TI-84 Plus to my Ubuntu 11.04 laptop. I use the organelle cables to connect it. The program tilp(2) didn't work or at least it didn't show my TI-84 Plus; I've tried to run it in root and in the normal way.

share|improve this question
up vote 11 down vote accepted

The libticables2-2 library supplied with Ubuntu 11.04 (and as of this writing, 11.10 too) supports the SilverLink cables only. I've just uploaded a patch which adds support for the TI-84+ calculator which is available in LP #747589.

Overview of the fix

  • Update the udev rules to avoid having to run the program as root
  • Adding yourself to the tilp group so you may use the device without running as root
  • Specify the calculator type to tilp

Instructions for installing tilp and getting it to work with the TI-84+:

  1. Install the tilp package and its dependencies like libticables2-2: sudo apt-get install tilp
  2. Download the patch:

  3. Apply the patch to the installed udev rules:

    sudo patch /lib/udev/rules.d/45-libticables.rules < new-devices-and-fixed-sysfs-warning.patch 
  4. Add yourself to the tilp group:

    sudo usermod -a -G tilp $USER
  5. Re-login to apply the group settings
  6. The TI-84+ uses an USB-A - USB-B connector which is called DirectLink. This should be detected automatically. Connect the calculator now to the computer. If you've previously had connected it already, disconnect and reconnect it.
  7. Now make known to tilp that you're using a TI-84+ calculator by running:

    tilp --calc=ti84+ --cable=DirectLink

    This will set the calc=TI84+ and cable_model=DirectLink in the ~/.tilp configuration file. After running the above command, it's sufficient to run just tilp in the future (using the application menu or by running the command directly).

share|improve this answer
This works greats except that you must start with "tilp --calc-ti84 --cable=DirectLink" Marked and voted up and droping windows even more. Thank you – Rens Sep 11 '11 at 9:46
I found out that you indeed have to include --cable=DirectLink the first time. Updated answer. – Lekensteyn Sep 11 '11 at 12:34

You likely need wineInstall wine1.3 installed in order to use the ti-84 tools. Wine is a Windows compatibility layer that allows you to run certain Windows applications in Linux. According to the Wine AppDB entry for the Graph Link software there may be some issues running the program (note that the results listed are a little old, so the program may work fine).

share|improve this answer
-1: op stated that tilp did not work. – Broam Jun 14 '11 at 20:20
@Broam: Ooops... I missed that. Good catch. My answer has been updated now. – Nathan Osman Jun 14 '11 at 20:26
@George Edison I have tried to use the ti link under wine but it does not mount. Under Tilp it also doesn't mount. – Rens Jun 14 '11 at 20:26
@Rens: It does not mount? Are you referring to the GraphLink software on the CD that came with your calculator? Do you mean that it doesn't install? – Nathan Osman Jun 14 '11 at 20:31
@George Edison no I'm referring to the calculator. – Rens Jun 15 '11 at 6:04

Perhaps TILP isn't working because of this bug?

Are you using a standard USB cable or the other connector? Can you see the device by typeing "lsusb" in terminal? Have you tried compiling a newer TILP? Unfortunately last I checked wine emulation didn't support USB, but Virtualbox Windows may work.

share|improve this answer
@user778234 When I type lsusb in terminal I can see the device. (Bus 002 Device 010: ID 0451:e003 Texas Instruments, Inc.) I don't know how to compil tilp – Rens Jun 15 '11 at 18:33
Looks like the latest version and documentation is here: but there's a PPA that may be easier to install. – NoBugs Jun 15 '11 at 19:27
@user778234 This doesn't work because of the bug – Rens Jun 16 '11 at 11:51
Have you tried connecting the TI-84 with a standard usb, not a silverlink cable? – NoBugs Jun 16 '11 at 23:41
@user778234 I've got two cable both don't work. – Rens Jun 17 '11 at 6:16

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.