Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

The Internet is full of this kind of issues, like the guys from ATI wouldn't even bother to test their installers. I am trying to get the latest driver because Skyrim (with Wine) freezes so badly that I have to un-plug/reset the computer. I am trying to see if the latest driver would fix that because the error is related to fglrx. By the way, the log is:

kernel: [   72.180644] fglrx_pci 0000:01:00.0: irq 48 for MSI/MSI-X
kernel: [   72.181039] <6>[fglrx] Firegl kernel thread PID: 1942
kernel: [   72.181101] <6>[fglrx] Firegl kernel thread PID: 1943
kernel: [   72.181163] <6>[fglrx] Firegl kernel thread PID: 1944
kernel: [   72.181230] <6>[fglrx] IRQ 48 Enabled
kernel: [   72.226636] <6>[fglrx] Reserved FB block: Shared offset:0, size:1000000 
kernel: [   72.226638] <6>[fglrx] Reserved FB block: Unshared offset:f878000, size:4000 
kernel: [   72.226639] <6>[fglrx] Reserved FB block: Unshared offset:f87c000, size:484000 
kernel: [   72.226640] <6>[fglrx] Reserved FB block: Unshared offset:7fff4000, size:c000 
anacron[1960]: Anacron 2.3 started on 2014-06-24
anacron[1960]: Normal exit (0 jobs run)
  1. So, here I go. I download the archive from ATI (linux-amd-catalyst-14.6-beta-v1.0-may23.zip) and extract the files.

  2. Now I uninstall the existing fglrx driver by doing this:

    sudo apt-get remove --purge fglrx fglrx_* fglrx-amdcccle* fglrx-dev*
    sudo dpkg-reconfigure xserver-xorg
    The first one works fine and I can see that fglrx is removed. The second one, obviously, throws me this sh*t:
    Package 'xserver-xorg' is not installed and no info is available.

  3. Anyway, I start the new driver's installer after going to its location:

    sudo ./amd-driver-installer-14.20-x86.x86_64.run

    The first error is this:
    ./lokixml.sh: 143: ./lokixml.sh: [[: not found

    The ugly setup window shows up and after I click Continue/I Agree/Continue I get a pop-up window (even uglier) telling me to go fu*k myself and check errors log.

  4. I decide to take them one by one so, in order to fix the first error I have to extract the .run file:
    ./amd-driver-installer-14.20-x86.x86_64.run --extract
    then open the file lokixml.sh from the folder, where I must comment out lines 143 to 145. After that I run the install script:
    sudo ./ati-installer.sh 14.20 --install

  5. The lokixml.sh error is gone but I still get the ugly pop-up so I go to the log file and find this:
    ./packages/Ubuntu/ati-packager.sh: 294: ./packages/Ubuntu/ati-packager.sh: debclean: not found dpkg-buildpackage: export CFLAGS from dpkg-buildflags (origin: vendor): -g -O2 -fstack-protector --param=ssp-buffer-size=4 -Wformat -Wformat-security dpkg-buildpackage: export CPPFLAGS from dpkg-buildflags (origin: vendor): -D_FORTIFY_SOURCE=2 dpkg-buildpackage: export CXXFLAGS from dpkg-buildflags (origin: vendor): -g -O2 -fstack-protector --param=ssp-buffer-size=4 -Wformat -Wformat-security dpkg-buildpackage: export FFLAGS from dpkg-buildflags (origin: vendor): -g -O2 dpkg-buildpackage: export LDFLAGS from dpkg-buildflags (origin: vendor): -Wl,-Bsymbolic-functions -Wl,-z,relro dpkg-buildpackage: source package fglrx-installer dpkg-buildpackage: source version 2:14.200-0ubuntu1 dpkg-buildpackage: source changed by AMD: Advanced Micro Devices. <http://ati.amd.com/support/driver.html> dpkg-source --before-build fglrx.hM3zeH dpkg-buildpackage: host architecture amd64 debian/rules build Can't exec "debian/rules": Permission denied at /usr/bin/dpkg-buildpackage line 529. dpkg-buildpackage: error: debian/rules build failed with unknown exit code -1 [Error] Generate Package - error generating package : Ubuntu/precise

  6. In this page I find out that I have to mount some temporary directory and then start the installer, so I do:
    mkdir ~/tmptmp sudo mount --bind ~/tmptmp /var/tmp sudo ./ati-installer.sh 14.20 --install sudo checkinstall make install sudo umount /var/tmp

    but I get the same pop-up and errors in the log file, so here is where I am stuck, with the previous driver uninstalled and the new one unable to be installed. My ATI card is a HD 7670 M, on a HP Pavillion G6 2306-sq

  7. I found another HowTo here but now, when I do:
    sudo sh ati-installer.sh 14.100/14.20 --buildpkg
    I get an error saying:

    parsechangelog/debian: warning: debian/changelog(l0): found eof where expected first heading parsechangelog/debian: error: fatal error occurred while parsing input dpkg-buildpackage: error: changelog parser /usr/lib/dpkg/parsechangelog/debian gave error exit status 255

    This is never ending

  8. After trying other solutions I have managed to mess it up completely. Black screen and no way to recover my files. So, I´m going back to Windows.

share|improve this question
1  
Just checking: Does point 8 mean you no longer need help? –  muru Jun 25 at 6:35
    
Whats your graphics card? –  mmm3743 Jul 1 at 11:20
    
Same problems! Been struggling with fglrx and crashy Xwindows ever since getting the Acer Aspire laptop. The credit (for the unacceptable quality and product+support failure) goes to ATI however. –  Marcos Aug 19 at 20:48
    
I can send you 3 deb files made (fglrx_14.200-0ubuntu_.deb, fglrx-amdcccle_14.200-0ubuntu_.deb, fglrx-dev_14.200-0ubuntu_.deb). Yet it logs Error! Bad return status for module build on kernel: 3.16.0-9-generic (x86_64) /var/lib/dkms/fglrx/14.200/build/make.log contains In function 'KCL_GetEffectiveUid': /var/lib/dkms/fglrx/14.200/build/2.6.x/firegl_public.c:1787:5: error: incompatible types when returning type 'kuid_t' but 'KCL_TYPE_Uid' was expected return current_euid(); Makefile:88: recipe for target 'kmod_build' failed build failed with return value 2 –  Marcos Aug 19 at 20:59
    
How exactly is this reproducible? –  Braiam Sep 13 at 17:38

2 Answers 2

For me (I have a headless machine) those installer options didn't work (probably because they fire up installer GUI), so what I needed to do is to build the packages.

Here is an official guide for building packages from AMD drivers, but for your concrete problem you would have to go to the directory with the package and run:

./amd-driver-installer-14.20-x86.x86_64.run --buildpkg Ubuntu/precise

This will create 3 packages that you can install with

sudo dpkg -i fglrx*.deb
share|improve this answer
    
Any comment why '-' ? –  Patryk Sep 13 at 22:09

Easy way to install, run in terminal:

sudo ./amd-driver.run

Then slect "Install Driver" and select "Continue"
Press "I agree"
Press "Contniue"
Restart PC

This error still occurs: "./lokixml.sh: 143: ./lokixml.sh: [[: not found", pay no attention to it

share|improve this answer
    
Why does the error occur? I don't like ignoring errors. –  Tim Sep 23 at 17:59
    
fix: devgurus.amd.com/thread/168923 I haven't tested it since I don't use amd's driver, I use open source one. Also why the down vote? –  mmm3743 Sep 25 at 0:05
    
Because you had said to just ignore the error. That article doesn't really explain it... Could you edit it in to make it part of your answer. –  Tim Sep 25 at 16:03
    
I have 3 things to say: 1, the error occurs because programmers added unnecessary [[ symbols. 2, the article does explain the error, the error will not affect the driver at all, those are just some config files that sort themselves out since you are too lazy to read 3, you couddn't even bother searching the google for "lokixml.sh", congrats... –  mmm3743 Sep 26 at 16:53
    
1: Okay, edit that in 2: quite hard to see that it explains and yep I'm lazy, just like a lot of people looking for answers, and 3: nope, I didn't want to bother my time for something you should have as part of your answer. Please edit in why it does that, because I currently can't (and wouldn't) take away that down vote. –  Tim Sep 26 at 17:15

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.