Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am trying to play Steam games on my computer running Ubuntu 14.04. On launching Team Fortress 2 I receive the error Cannot find required OpenGL entry point 'glGetError'! Either your video card is unsupported, or your OpenGL driver need to be updated.

I tried sudo rm /usr/lib/i386-linux-gnu/libGL.so and rm .local/share/Steam/ubuntu12_32/steam-runtime/i386/lib/i386-linux-gnu/libgcc_s.so.1 with no luck. What is going wrong exactly and how should I attempt to go about fixing it.

I am using integrated Intel graphics. System settings call it an Intel® 945G x86/MMX/SSE2.

My driver is an Intel Open Source Technology Center Mesa DRI Intel(R) 945G x86/MMX/SSE2

share|improve this question
1  
What's your graphics card and what driver are you using? –  Xweque Jul 6 at 16:35
1  
I don't see how removing those files would help you resolve this error. I would begin by looking to see if the video card is supported, and if so updating the driver would seem the next logical step. –  Elder Geek Jul 6 at 20:31
    
I believe I am using an Intel graphics card. System settings call it an Intel® 945G x86/MMX/SSE2. My driver is a Intel Open Source Technology Center Mesa DRI Intel(R) 945G x86/MMX/SSE2 . I am about to pop open my computer to check exactly what GPU I have. –  Cammy_the_block Jul 6 at 20:43
1  
It sounds like integrated graphics on the motherboard. –  Elder Geek Jul 6 at 20:51
    
Yeah, your right. It turned out to be built into the mother board, the "Intel Desktop Board". –  Cammy_the_block Jul 6 at 20:53

2 Answers 2

What is going wrong exactly:

Your video card is unsupported or your OpenGL driver needs to be updated.

How to fix it:

A) Obtain a high end supported video card - This is the solution I recommend

Minimum Required: A DirectX 8.1 compatible video card

Recommended: A DirectX 9 compatible video card

Numerous sources found googling "Team Fortress 2 system requirements"

B) Try 2014Q2 Intel Graphics Stack Release available here:

https://01.org/linuxgraphics/downloads/2014/2014q2-intel-graphics-stack-release

Be aware that I don't believe that you will be happy with the performance provided by the 82945G graphics for gaming which is why I personally don't recommend option B, but I'm including it here for the sake of completeness.

You may also need to reinstall the GCC support library (libgcc1) as you appear to have deleted some of it's components

share|improve this answer
    
Intel claims that Intel 945G supports DirectX 9. (intel.com/support/graphics/sb/CS-033757.htm#olderGraphics) –  Cammy_the_block Jul 7 at 0:34
    
Updated answer. –  Elder Geek Jul 7 at 1:39
    
Sorry, which do I download for B? –  Cammy_the_block Jul 7 at 2:40
1  
@Cammy_the_block Ubuntu doesn't use DirectX... –  Mateo_ Jul 7 at 15:53
1  
I'm referring to keeping an open mind and understanding that just because an answer isn't what you want doesn't mean it's wrong. –  Elder Geek Jul 7 at 21:04

It seems that instead of using the default drivers that come with Ubuntu (the drivers I recommend using), you are using Intel's open-source drivers. If you have Intel's drivers installed, you probably have a program called "Linux Graphics Installer" or something similar that is an option if you open System Settings and scroll all the way down. Use that program to remove Intel's drivers. Then reboot and try playing your game again. If you have the exact same problem, open System Settings and choose "Additional Drivers". It's pretty self-explanatory once you're there but you gotta try to change your video card's driver back to what it was when you first installed Ubuntu, as that is probably the one that works the best. Also, update to Ubuntu 14.04 Trusty Tahr if you have not done so already. I hope this helps.

share|improve this answer
1  
There is no graphics card drivers in "Additional Drivers." –  Cammy_the_block Jul 14 at 3:20
    
Nevermind then. –  FuzzyToothpaste Jul 14 at 16:03

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.