Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I just built a new computer last week, and this weekend I got around to attempting to install Ubuntu 14.04 on it besides Windows 7. This is my first experience really using UEFI, so I was a little surprised that the install process didn't just work for me. No matter what I did, I always ended up with a prompt saying

Unable to find a medium containing a live file system

and I was unable to type anything, though that may be due to my wireless keyboard (wired is on the way). This prompt always comes up after sitting at the Ubuntu loading screen for about ~2-3 minutes.

I made sure the ISO I downloaded was fine by checking the MD5Sum. Rebuilt the bootable usb (using UNetbootin) twice, no luck. The only thing I was not able to do was turn off secure boot, because I was not able to find the option on my motherboad (Gigabyte 970A-UD3P). I'm not even sure if that's a UEFI feature, or if it's just a Windows 8 feature.

I have verified that I am indeed using USB2.0 ports, and not USB3.0. I am rather lost and not sure how to proceed at this point. Any more guidance would be greatly appreciated! I really despise developing on Windows -_-

EDIT: more attempts: Ok, I have tried this some more. I have now used Rufus, LiveLinux USB Creator, and Universal USB Installer. None of these have done it either. I have bought a brand new flash drive, that didn't work. Every single time it is the same story. Ubuntu loading screen for about 2 minutes, then kicked into an ash console with the message of "Unable to find a medium containing a live file system". I'm not even able to type at all at this point, so I can't really get any more information. This is incredibly frustrating. I have never had this much trouble getting Linux installed before.

HARDWARE:

Gigabyte 970A-UD3P

AMD FX8350

GTX 760

Skill Ripjaw 2x4GB RAM

1TB HDD

share|improve this question
    
Secure boot is broken anyway, you can disable it if there's such option in BIOS. –  user31389 Jun 29 at 19:16

4 Answers 4

up vote 2 down vote accepted
+100

While a different model Gigabyte mother board this may also apply.

Gigabyte GA-X79-UD3 with I7-3820 Needed F6 to set ACPI=Off.and nomodeset

Gigabyte UEFI boot issues - The partition size of the created USB Installer device needs to be under that of 4GB. Others found UEFI/BIOS update solved issue of 4GB FAT limit.

turns out the IOMMU needs to be enabled in the BIOS. This problems seems to be exclusive to Gigabyte boards.

Some more related info: IOMMU for USB3 ports Gigabyte board

http://ubuntuforums.org/showthread.php?t=2188370

Linux kernel enable the IOMMU – input / output memory management unit support - AMD

http://www.cyberciti.biz/tips/howto-turn-on-linux-software-iommu-support.html

share|improve this answer
    
IOMMU was my issue. Still not sure why that affects USB ports. –  ResidentBiscuit Jun 30 at 13:41

Don't use unetbootin. My experience with it is limited, but the last I heard, its support for EFI-mode booting was poor or non-existent. In my experience, the most reliable way to create an EFI-bootable USB flash drive of an Ubuntu installer is to use dd in Linux, or a port of dd to Windows or whatever other OS you can use:

sudo dd if=imagefile.iso of=/dev/sdc

Change the if= and of= options as appropriate.

If you're using Windows, my limited experience with Rufus has also been positive.

For more on EFI-mode installs generally, see my Web page on the subject or the Ubuntu community wiki. Both provide accurate information. Much of the advice on the Internet about EFI-mode installs is misguided.

share|improve this answer
    
I'll give dd a try. I have Ubuntu on my laptop I can use it on. I was never able to find any other software besides Unetbootin on Windows to create a bootable USB. –  ResidentBiscuit Jun 24 at 17:47
    
I have tried this, and more to no avail. Updating question. –  ResidentBiscuit Jun 28 at 19:16
    
I think it was a Intel based board, but users have posted these as issues. Needed F6 to set ACPI=Off.and nomodeset Gigabyte UEFI boot issues - The partition size of the created USB Installer device needs to be under that of 4GB. Others found UEFI/BIOS update solved issue of 4GB FAT limit. turns out the IOMMU needs to be enabled in the BIOS. This problems seems to be exclusive to Gigabyte boards. –  oldfred Jun 28 at 19:32
1  
Wow turning on IOMMU did it. I have absolutely no idea why though. I don't see why IOMMU is even relevant to this –  ResidentBiscuit Jun 28 at 20:19
    
@ResidentBiscuit if you have Ubuntu on a laptop, you could use the Startup Disk Creator on it. Or Universal USB Installer on Windows. –  muru Jun 29 at 16:30

Try Pen Drive Linux's USB installer as the Ubuntu website explains.

And for installing Ubuntu I recommend following the procedures noted here which includes:

  • creating a partition for /boot;

  • selecting the /boot partition as the boot loader;

  • installing Ubuntu;

  • making a boot item using EasyBCD on Windows.

share|improve this answer
    
Please read up on what UEFI is. You can install more than one bootloader on an ESP and don't need to rely on chainloading quirks like EasyBCD. –  LiveWireBT Jun 30 at 10:52
    
:) But I couldn't. This was what I could do with success. –  AliNa Jun 30 at 11:37

First decide which firmware interface to be used EFI or Legacy mode . This will help you to decide.
For uefi + Windows 8 see @Luis Alvarado's answer at installing-ubuntu-on-a-pre-installed-windows-8-64-bit-system-uefi-supported.
If you can't boot try the following.

  • Use legacy mode (no uefi)
  • Use USB 2.0 port (no USB 3)
  • Remove all unwanted devices (USB, memory card)
  • Disable QuickBoot/FastBoot from Windows
  • Try UHCI or OHCI Host Controller (no xHCI)

For error

Unable to find a medium containing a live file system

As you get this error after loading the boot-loader you can load the operating system to RAM but edit and adding toram option to the kernel. For this , after loading boot-loader, press any arrow key to pause add option toram to the line that load kernel. For example linux /casper/vmlinuz boot=casper will become linux /casper/vmlinuz toram boot=casper .

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.