Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This is definitely NOT a duplicate. The "possible duplicate" I even said I tried in the original question. As for anything else, well, 16 comments and 1 answer that didn't work. It's clearly not a generic or common solution as the other questions like mine.

     ian@ian:~$ sudo apt-get install skype
    [sudo] password for ian: 
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    Some packages could not be installed. This may mean that you have
    requested an impossible situation or if you are using the unstable
    distribution that some required packages have not yet been created
    or been moved out of Incoming.
    The following information may help to resolve the situation:

    The following packages have unmet dependencies:
     skype : Depends: skype-bin
    E: Unable to correct problems, you have held broken packages.`

I've tried every solution for every question similar to "you have held broken packages," including those in How do I resolve unmet dependencies?. I've purged every ppa, and I've no idea what to try now. apt-mark showhold gave no output. My sources.list is below. Thanks for any help.

# deb cdrom:[Ubuntu 14.04 LTS _Trusty Tahr_ - Release amd64 (20140417)]/ trusty main restricted

# See http://help.ubuntu.com/community/UpgradeNotes for how to upgrade to
# newer versions of the distribution.
deb http://us.archive.ubuntu.com/ubuntu/ trusty main restricted
deb-src http://us.archive.ubuntu.com/ubuntu/ trusty main restricted

## Major bug fix updates produced after the final release of the
## distribution.
deb http://us.archive.ubuntu.com/ubuntu/ trusty-updates main restricted
deb-src http://us.archive.ubuntu.com/ubuntu/ trusty-updates main restricted

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team. Also, please note that software in universe WILL NOT receive any
## review or updates from the Ubuntu security team.
deb http://us.archive.ubuntu.com/ubuntu/ trusty universe
deb-src http://us.archive.ubuntu.com/ubuntu/ trusty universe
deb http://us.archive.ubuntu.com/ubuntu/ trusty-updates universe
deb-src http://us.archive.ubuntu.com/ubuntu/ trusty-updates universe

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu 
## team, and may not be under a free licence. Please satisfy yourself as to 
## your rights to use the software. Also, please note that software in 
## multiverse WILL NOT receive any review or updates from the Ubuntu
## security team.
deb http://us.archive.ubuntu.com/ubuntu/ trusty multiverse
deb-src http://us.archive.ubuntu.com/ubuntu/ trusty multiverse
deb http://us.archive.ubuntu.com/ubuntu/ trusty-updates multiverse
deb-src http://us.archive.ubuntu.com/ubuntu/ trusty-updates multiverse

## N.B. software from this repository may not have been tested as
## extensively as that contained in the main release, although it includes
## newer versions of some applications which may provide useful features.
## Also, please note that software in backports WILL NOT receive any review
## or updates from the Ubuntu security team.
deb http://us.archive.ubuntu.com/ubuntu/ trusty-backports main restricted universe multiverse
deb-src http://us.archive.ubuntu.com/ubuntu/ trusty-backports main restricted universe multiverse

deb http://security.ubuntu.com/ubuntu trusty-security main restricted
deb-src http://security.ubuntu.com/ubuntu trusty-security main restricted
deb http://security.ubuntu.com/ubuntu trusty-security universe
deb-src http://security.ubuntu.com/ubuntu trusty-security universe
deb http://security.ubuntu.com/ubuntu trusty-security multiverse
deb-src http://security.ubuntu.com/ubuntu trusty-security multiverse

## Uncomment the following two lines to add software from Canonical's
## 'partner' repository.
## This software is not part of Ubuntu, but is offered by Canonical and the
## respective vendors as a service to Ubuntu users.
deb http://archive.canonical.com/ubuntu trusty partner
# deb-src http://archive.canonical.com/ubuntu trusty partner

## This software is not part of Ubuntu, but is offered by third-party
## developers who want to ship their latest software.
deb http://extras.ubuntu.com/ubuntu trusty main
# deb-src http://extras.ubuntu.com/ubuntu trusty main

After entering sudo apt-get install skype-bin skype libqtwebkit4 libqtgui4, I got this:

ian@ian:~$ sudo apt-get install skype-bin skype libqtwebkit4 libqtgui4 libqtgui4:i386 libqtwebkit4:i386 libtiff5:i386 libjbig0:i386
Reading package lists... Done
Building dependency tree       
Reading state information... Done
libqtgui4 is already the newest version.
libqtwebkit4 is already the newest version.
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libjbig0 : Breaks: libjbig0:i386 (!= 2.0-2+deb7u1) but 2.0-2ubuntu4.1 is to be installed
 libjbig0:i386 : Breaks: libjbig0 (!= 2.0-2ubuntu4.1) but 2.0-2+deb7u1 is to be installed
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.
share|improve this question
    
what is being said is that sky requires something that if you get it, it will break your system. The Held packages are dependencies that cannot be installed. Are you installing from source? (if you aren't, try installing from source) –  j0h Jun 24 at 13:40
    
No, I've tried with sudo apt-get install, synaptic, and ubuntu software manager. All of them gave the same error. It happens with a lot of other packages too, one of them being any wine version. I tried ubuntu-restricted-extras just to see and that one worked fine. Oh, also, I had skype on this exact same computer and ubuntu installation a few weeks ago and it worked fine, but I uninstalled it. Now I can't reinstall. –  FourZer0 Jun 24 at 13:43
    
try sudo apt-get install -f –  M.Tarun Jun 24 at 13:45
    
I've tried all of those sort of commands, autoclean, clean, dist-upgrade, etc. –  FourZer0 Jun 24 at 13:50
    
I think I've narrowed it down to one package - libqtgui4:i386, according to appgrid, if that helps at all –  FourZer0 Jun 24 at 13:52

1 Answer 1

Try with:

sudo apt-get install skype-bin skype libqtwebkit4 libqtgui4 libtiff5 libjbig0
share|improve this answer
    
The following packages have unmet dependencies: skype-bin:i386 : Depends: libqtgui4:i386 (>= 4:4.8.0) but it is not going to be installed Depends: libqtwebkit4:i386 (>= 2.2~2011week36) but it is not going to be installed Recommends: sni-qt:i386 but it is not going to be installed E: Unable to correct problems, you have held broken packages. –  FourZer0 Jun 24 at 14:31
    
in such a case add the is not going to be installed packages to the main installation list. I edited the answer. –  user308564 Jun 24 at 14:34
    
I kept adding on for a while, and came to a different error. Too long, so I put it in the bottom of my question. –  FourZer0 Jun 24 at 14:42
    
There is no such package called libqtwebkit4:i386. It is libqtwebkit4. Remove the :i386 from all. –  user308564 Jun 24 at 14:46
    
Removed :i386 from all the package names, got The following packages have unmet dependencies: skype-bin:i386 : Depends: libqtgui4:i386 (>= 4:4.8.0) but it is not going to be installed Depends: libqtwebkit4:i386 (>= 2.2~2011week36) but it is not going to be installed Recommends: sni-qt:i386 but it is not going to be installed E: Unable to correct problems, you have held broken packages. –  FourZer0 Jun 24 at 14:54

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.