Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I run steam via wine. I tried to run it with my nvidia card but get the following error when running optirun wine Steam:

 wine: error while loading shared libraries: libturbojpeg.so: wrong ELF class: ELFCLASS64

I know that it has something to do with the package is not 32bit compitable. I tried what was suggested here, but did not work. I think that is caused by the fact that I run Steam through, isn't it?

share|improve this question
    
The answer that you linked should work. Did you try to change your LD_LIBRARY_PATH? Try run steam from command line using this: LD_LIBRARY_PATH=/usr/lib32:$LD_LIBRARY_PATH steam install some_game, or LD_LIBRARY_PATH=/usr/lib32:$LD_LIBRARY_PATH steam play some_game –  c0rp Jun 23 at 17:35
    
I can't not run steam like that because it is installed via wine I run it with wine Steam and LD_LIBRARY_PATH=/usr/lib32:$LD_LIBRARY_PATH optirun wine Steam, did not work. Same error message... –  markusw Jun 23 at 18:41

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.