Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'd like to be able to lock my screen consistently and require a password.

  1. Pressing the 'Lock' icon on the panel at the top blanks the screen, and prompts me for a password to unlock
  2. Pressing CTRL-ALT-L blanks the screen, but does not require a password to unlock
  3. Letting the screensaver activate does not require a password to unlock.

Any suggestions? I'm hoping I can change something so that any time the screen is locked in any manner it will require a password.

share|improve this question
    
Are you still experiencing this issue? –  Tom Brossman Mar 9 '12 at 9:30
    
No, it seems to be fixed now –  Alex Black Mar 12 '12 at 16:57
    
I will assume this was fixed with an updated package and no longer requires an answer, please feel free to flag it to be re-open if that issue still needs to be solved. –  Bruno Pereira Mar 12 '12 at 20:53
add comment

closed as too localized by Bruno Pereira Mar 12 '12 at 20:51

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

1 Answer

Check to ensure your screensaver has the appropriate option enabled.

First, open system settings.

Next, select Screensaver.

Lastly, ensure that 'Lock screen when screensaver is active' is enabled.

If you find that the 'Lock screen when screensaver is active' option is enabled, start gconf-editor and under apps > gnome-screensaver, verify that the 'lock_delay' is set to 0.

share|improve this answer
    
Thanks Kory, that setting is enabled. Note: the problem happens when I press CTRL-ALT-L also, which is meant to lock the screen directly. –  Alex Black Jun 15 '11 at 0:21
    
I was hoping that there was a difference between CTRL-ALT-L and the Lock button. Let me see what else I am able to dig up. –  Kory Wnuk Jun 15 '11 at 0:24
    
Hi Kory, good ideas.. I did google before posting the question, and came across similar info to what you've discovered. lock_delay is indeed set to 0. –  Alex Black Jun 15 '11 at 12:39
    
It is bizarre that CTRL-ALT-L and the 'lock button' do different things on my install (Ubuntu 10.10 x64) –  Alex Black Jun 15 '11 at 12:40
    
It is odd that there is different behavior experienced. My thought regarding the 'lock_delay' was that you were experiencing similar end results when either using CTRL-ALT-L and when screensaver was activate by virtue of timed inactivity. A challenging problem for sure. –  Kory Wnuk Jun 15 '11 at 21:51
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.