Sign up ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

Possible Duplicate:
How to make Ubuntu remember forever the password after the first time

I put my password in when I log in but after that I don't want to type it again.

When I use my laptop I only wants to put in my password when I log in and never when I'm logged in.

The point of this is that I don't want to waste time typing my password every time I do some administrative task. I'm the only user and is very tired of having to type my password over and over again.

share|improve this question

marked as duplicate by Jorge Castro, Marco Ceppi Jun 14 '11 at 20:35

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

But I want to put in my password when I log in (for security.) But I don't want to put in my password after that. – Alvar Jun 14 '11 at 11:44
This might be a security issue if someone else get access to your computer. – N.N. Jun 14 '11 at 12:08
@N.N that wont happen since I always lock my screen before I leave my computer and I always require a password when I log in! – Alvar Jun 14 '11 at 14:32
@Alvar What about network access? – N.N. Jun 14 '11 at 14:38

1 Answer 1

Being able to run command with administrative privileges without entering a password is like doing everything as root. It's strongly discouraged to disable the password for sudo, although it's possible.

To skip asking for a password when installing programs, see:

If you want to be able to use sudo without asking for a password (not recommended), follow the instructions at:

share|improve this answer
I want to use my passwd to log in, but after that I dont want to type it again, I lock my screen when I leave it, and if someone trys to access it from the internet then they MUST type in the passwd, if that is the case, why is this a security problem? – Alvar Jun 14 '11 at 16:22
You're missing one serious issue: the possibility that code may be executed due to a bug or uncareful handling of code from the Internet. Consider changing the expiration time for a sudo session instead: – Lekensteyn Jun 15 '11 at 8:28

Not the answer you're looking for? Browse other questions tagged or ask your own question.