Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have Broadcom bcm43224 wifi card with proprietary broadcom sta driver. At home wifi connection works well, but in the office when I ping some resource there is a lot of loss packets and I cant browse websites.

I have tried another way to check internet connection - download file with wget.

wget - very slow speed

wget -4 - normal speed

So, it seems that the problem is with the ipv6 configuration at the office, can I force my wifi connection to use only ipv4 and completely ignore ipv6 ?.

share|improve this question
Is it slow only at first or slow for the whole download (maybe try something bigger than a webpage to test this)? – Azendale Jun 16 '11 at 1:15
In first case I wait at least about 1 min for host resolving and file downloading, the second works much faster. – krasilich Jun 16 '11 at 14:58

yes, you can set using ipv6 in menu system -> preferences -> network connection. Choose which connection you want to use without ipv6, then click edit, go to tab ipv6 settings and choose method ignore.

( this doesnt cover situations when you have some ipv6 tunnel enabled )

share|improve this answer
the problem is that I already have 'Ignore' on ipv6 tab for my connection... – krasilich Jun 14 '11 at 14:23
interesting... maybe link local will help, dunno, ipv6 working here just fine. maybe you can try this page – Denwerko Jun 14 '11 at 16:53

This sounds like it could be that you are using a DNS server that doesn't do very well with requests for an IPv6 address. Instead of just saying it doesn't know how to handle those requests, it waits for a very long time and then your computer retries again but asking for a IPv4 address the second time around.

An easy way to test this (using your example) is to run dig a and dig aaaa If the 'dig aaaa' command take considerably longer, your computer is picking up a misbehaving DNS server from your office network's DHCP.

So, let's change to using a DNS server that handles those requests correctly instead of disabling IPv6 (which we should be migrating to soon). Go to the network manager, select your wireless connection, and click edit. Go to the IPv4 tab and for method pick 'Automatic (DHCP) Addresses Only'. In the DNS servers field put '' and click Save. Reconnect to the connection and see if that speeds anything up.

share|improve this answer
I tried to use dig from your example and in both cases I got the same result ; <<>> DiG 9.7.3 <<>> aaaa ;; global options: +cmd ;; connection timed out; no servers could be reached – krasilich Jun 21 '11 at 13:24
@krasilich That's real weird. It would seem to indicate that you shouldn't be able to resolve (translate from to addresses like anything. You could still try the solution; it might fix both the original problem and the error you just got. – Azendale Jun 22 '11 at 6:03

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.