Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I did searched the FAQs about kernel updates, here are somethings I wanna confirm

  1. I learned that I could go to http://kernel.ubuntu.com/~kernel-ppa/mainline/v2.6.39.1-oneiric/ to get latest kernel for 10.10 Maverick, even though it's named under Oneiric.

  2. Will there be any issue regarding to software updates and so forth after I installed the new kernel? (My worry is that all PPA is added based on Maverick and now the kernel is different from the original one)

  3. What other disadvantage will there be?

share|improve this question

3 Answers 3

up vote 1 down vote accepted

I guess there shouldn't be a problem regarding system stability in general with the addition of this PPA and the installation of this and/or subsequent kernels.

After all, new versions are added up to the list of the already installed kernels, they don't replace the old ones. If a new kernel breaks your system, you can always reboot and select one of the others.

As for the software updates, i also don't think that you're gonna face serious issues.
Most of the kernel development has to do with low-level programming (IRQs, hardware compatibility issues, etc) and minor version upgrades might produce some incompatibilities, but probably won't break your whole system.

As you state in your comment to akbozo, you're willing to test your system and don't have a problem reinstalling if something goes wrong.

So I'd say you go with it.

share|improve this answer
    
Thanks for your encouragement above all! I will sure to explore. But I need to say what I posted is not a PPA. Is it still OK for me to go? –  BiteMac Jun 14 '11 at 8:04
    
Yes it is. This is a PPA, you just don't wanna add it to your list of repositories. You will just download and install a specific package from there. Do it ;-) –  Pavlos G. Jun 14 '11 at 8:12
    
Oh I see it now. Thanks! But after upgrading the kernel. In terminal it says "maybe missing firmware" or something. And every time I start the computer, the Plymouth now displays ubuntu 10.10 and many line of words... Is this normal? –  BiteMac Jun 15 '11 at 0:53
    
This is normal for "not supported" kernels –  Extender Jun 15 '11 at 9:40

i tried it and my system crashed, like totally. i'm 61 years old and do not normally use phrases such as that; but installing the newest kernel can, may crash your system. stick with what you have for now. i'm upgrading to zorin 5. will do a clean install. i have tried upgrading to a new kernel several times and have had major problems every time.

share|improve this answer
    
Thanks for the tips akbozo. As stability goes, I would certainly stick to LTS version. But right now I am just curious on how the kernel upgrading works and wouldn't mind re-install my system again and again. Of course all my essential data have been well backed up already :P –  BiteMac Jun 14 '11 at 6:48
    
been there, done that. i have done so much experimenting that i have rebuilt from scratch 3 or 4 times a month over a 2 year period. go for it, have fun; as i have had. just make sure you back up everything to an external hard drive, sync your bookmarks, all your important data, but, you already know that, right. i learned the hard way. not all releases are backwards compatible. –  user19888 Jun 14 '11 at 7:48
    
I learned it the hard way year ago under windows. Since then I start to pay attention to backups. Yet mostly I found photos of highest value to me. Everything else is re-collectible. Bookmark cloud syncing is really a handy function build-in to Chrome. Loved it for the first second. :) –  BiteMac Jun 14 '11 at 8:07

I Used Kernelcheck to Get the latest Kernel, it Compiles the kernel by itself without the user doing pretty much anything.

I'm not using it however as the ATI driver 11.5 doesn't support the kernel 2.6.39 yet.

share|improve this answer
    
I heard that ATI display is not so well packed up under Linux. So I just switched to my older NV card instead, as I don't plan to play big 3D games in the near future :P –  BiteMac Jun 15 '11 at 0:54
    
Well you heard wrong, ATI drivers work fine in Linux is just that when a new kernel is released, we have to wait until AMD releases a new driver with the latest kernel support. –  Uri Herrera Jun 15 '11 at 2:23
    
Oh I see. Guess I'll plug my ATI card back in some time later :P –  BiteMac Jun 15 '11 at 7:45
    
This kernel is not working for NV too :) –  Extender Jun 15 '11 at 9:38
    
@Extender nvidia just released a new driver , have you tried it? –  Uri Herrera Jun 15 '11 at 10:20

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.