Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I recently dug an old Dell Inspiron 530S thin client out of a storage room, in hopes of getting it up and running to use at my desk. However I found that XP had screwed up and there were several sector read errors. I didn't want XP anyways and I decided to install Ubuntu by way of Wubi. I ran the Wubi installer and set a username and password in the installer. This was all great until I decided to start up Ubuntu and found that they user name I had created DID NOT EXIST! SO, much more research went into the issue and I found that I could access the root account if I could boot into recovery, something I was rather familiar with from previous issues. Although this time, it didn't want to go into recovery. It pulled up a screen in which many lines of text spewed across, loading mouse, loading key board, etc. But when it was about to launch into recovery mode, it stopped, and started to load Ubuntu as normal. I have tried to boot into recovery several times and I haven't been able to get it.

What would be my next steps in attacking the problem, I have an Ubuntu disk, but for some reason it never worked when I tried to boot from it. Giving an error that means you have to change some directory names, something I found to be common with USB Installs.

I currently have NTLDR on the MBR, although I would like to have GRUB2.

If all else fails, I will just download Ubuntu Server Distro and install it. I normally use Ubuntu Server Distro for my desktops anyway due to the versatility and customization that the desktop Distro doesn't offer.

share|improve this question

closed as unclear what you're asking by Braiam, Eric Carvalho, Warren Hill, psusi, bodhi.zazen Jul 21 at 17:17

Please clarify your specific problem or add additional details to highlight exactly what you need. As it's currently written, it’s hard to tell exactly what you're asking. See the How to Ask page for help clarifying this question.If this question can be reworded to fit the rules in the help center, please edit the question.

1  
If you have bad sectors in your hard drive I would rather don't use the NTFS partition at all, like WUBI does. Install Ubuntu in a brand new partition and I'm sure the problems will go away. –  Braiam Jun 21 at 15:51
    
I have tried that by installing Unix on a seperate hard drive that i know is good. Unless somehow the bad hard drive messed up the good one, is this possible, I know it is if you have raid configured, but I dont have RAID. –  JVarhol Jun 21 at 16:06
2  
WUBI is a) deprecated now (what version of Ubuntu are you trying to install?) b) uses your NTFS drive, so if XP is borked how could you expect Ubuntu to work fine on the same drive? –  Seth Jun 23 at 22:36

1 Answer 1

  1. Restart PC. Press & hold “Shift key“

  2. Select Recovery mode with up/down arrows & press “e” key.

  3. Find “Linux/boot/vminuz 3.2.0…….” line

  4. Remove ” or recovery nomodeset” words & replace ” rw init=/bin/bash“

  5. press “F10” then pc will reboot

  6. Then type ” /usr/sbin/usermod -p ‘!’ root (if you need to reset another user ,replace the username with root)

  7. passwd root

  8. set new password & press Alt+Ctrl+Del

share|improve this answer
    
I tried this and I can get to the screen where it is loading recovery, the one with lots of text and info scrolling down the screen, but then the last thing it says it mount:can't read proc/mounts. Can't fount such file or directory. And then it starts to load ubuntu normally, not i n recovery mode. –  JVarhol Jun 21 at 16:08
    
This is at my work, I may have to take it home and use another PC to format the drive. If I cant take it home I will have to wait until monday –  JVarhol Jun 21 at 16:09

Not the answer you're looking for? Browse other questions tagged or ask your own question.