Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I've set the following data in Thunderbird's config editor:

network.protocol-handler.app.http;x-www-browser
network.protocol-handler.app.https;x-www-browser

As soon as I did this, http: links are opened with x-www-browser (which currently links Google Chrome), but https: links are still opened in my old default browser, Chromium.

How can I fix this?

share|improve this question
up vote 2 down vote accepted
  1. Launch Thunderbird.

  2. Click on the menu button.

    M

  3. Click on Preferences.

    Pr1

  4. Again click on Preferences.

    PR2

  5. Then goto the Advanced tab.

    AT

  6. Click on Config Editor.

    CE

  7. Pass through the Warranty by clicking "I'll be careful, I promise!".

    W

  8. Then search for "network.protocol-handler.warn-external.http". And change the value to true by double-clicking both the entry.

    http

  9. Then, search for "network.protocol-handler.warn-external.ftp". And change the value to true by double-clicking both the entry.

    ftp

Now, you will be able to launch your default browser on clicking on any link.

Hope this helps!

share|improve this answer
    
Didn't work for me, Thunderbird still launches Chromium in spite of my configuration. – Eusebius Nov 19 '15 at 10:28

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.