Sign up ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

I run Ubuntu 14.04 on a Sony Vaio CS series laptop. Normally, the volume is controlled by pressing Funcion+F2, F3, and F4 for mute, volume down, and volume up respectively. I accidentally reassigned the volume up keyboard shortcut to a different key. I tried resetting the keyboard shortcut by going into the keyboard shortcuts editor in Ubuntu and pressing Function+F4, but that didn't work. My mute function and my volume down functions both work flawlessly, but volume up doesn't work at all. Please don't answer telling me to change the keyboard shortcut in the Keyboard Shortcuts manager, as I have already tried that. Thanks for your help!

share|improve this question
Same problem here... It was working fine in 13.04 but now nothing in 14.04.1 – user318582 Aug 20 '14 at 4:16

1 Answer 1

I found a bug report on launchpad regarding this issue and it seems when reassigning the media keys some prefix is missing. The following lines are somewhat of a summary of what is discussed in bug report

You can issue the following command to see your current keybinding:

gsettings get volume-up

Output should be XF86AudioRaiseVolume but when I use system setting's GUI and check I find it's value to be AudioRaiseVolume.

You can either reset them via either:

gsettings reset volume-up


gsettings set volume-up "XF86AudioRaiseVolume"

Of course the latter is more specific and might not work with all systems out there but I I was happy to find out it's just the string XF86 missing so e.g. I could bind terminal to calculator media key:

gsettings set terminal "XF86Calculator"

For a list of possible keys to map you can use

 gsettings list-keys

play is actually play/pause !

If your setup is different you might want to figure out your media key's name and set it via dconf. I haven't done it myself but it is mentioned in a comment which in turns links back to another askubuntu-question: Where are GNOME keyboard shortcuts stored?.

Edit: Couldn't help but to play around with it a little bit and as my keyboard is lacking some Previous/Next buttons I found CTRL+Volume-Down/CTRL+Volume-Up useful:

gsettings set previous "<Primary>XF86AudioLowerVolume"
gsettings set next "<Primary>XF86AudioRaiseVolume"
share|improve this answer
Replacing AudioRaiseVolume to XF86AudioRaiseVolume fixed a similar problem I had. Thank you :D – MinecraftShamrock Sep 27 '14 at 14:48
This works. The bugfix has been backported to 14.04, currently it's in the trusty-proposed repository. You can enable the repository in the Software & Updates control panel and then the sound should also work with just AudioRaiseVolume. – jmiserez Jan 23 at 5:35
@yoshi You mentioned "when I use system setting's GUI and check I find it's value to be AudioRaiseVolume". How can I access the setting's GUI? I'm running Lubuntu 15.04 – Hamman Samuel Sep 23 at 14:36
@HammanSamuel I refer to the general system settings and more specifically they keyboard option where short cuts can be set up. However I'm running ubuntu12.04 so experience may vary :/ – yoshi Sep 28 at 16:36
No luck for me. The prefix was there like it should be when I ran this command :\ What's strange is if I go through keyboard shortcuts, the prefix is missing (where as it's there for the buttons that are working, e.g. Mute), but this command shows the prefix. – MichaelChirico Sep 28 at 18:21

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.