Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm attempting to install Ubuntu server on a Virtualbox machine. Every time I attempt to install I get the following:

this kernel requires an x86-64 CPU, but only detects an i686 CPU, unable to boot

I'm running virtualbox on Ubuntu Server 14.04 (64 bit). I've been able to successfully run Arch Linux (64 bit) just fine on the same virtualbox install.

These are the settings I have for VM:

  • Enable VT-x/AMD-V is checked

share|improve this question

closed as off-topic by i08in, Luis Alvarado Jul 25 at 1:00

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "This describes a problem that can't be reproduced that seemingly went away on its own or was only relevant to a very specific period of time. It's off-topic as it's unlikely to help future readers." – i08in, Luis Alvarado
If this question can be reworded to fit the rules in the help center, please edit the question.

    
The arch iso is a dual iso, as in the one ISO file has the i386 and AMD64. Try using the 32 bit iso, I can guarantee you'll get Ubuntu running –  Jbuch14 Jun 20 at 16:05
    
@jbuch14 That will work for getting a machine up and running. Though I would like to figure out why it isn't working with 64 bit considering I am using a 64 bit processor with virtualization enabled in my BIOS. –  Csmarkus Jun 20 at 16:14

2 Answers 2

up vote 1 down vote accepted

I will update it if need. but I have no virtualbox around here to make a step by step

Do you have a PENTIUM 4? if less then is weird you have successfully running your 64 bits archlinux .

I think you should at least do this :

  1. Try a creating a new VM
  2. Enable VT-x/AMD-V or similar at your bios too
  3. Have a 64 bits host ( archlinux proves you already have it :c )
  4. Give at least two cores to your ubuntu server 64bits VM
share|improve this answer
    
i5-2500k. I'll try throwing two cores at it to see if that makes a difference. Edit: Same result with 2 cores. =\ –  Csmarkus Jun 20 at 16:24
1  
Oddly tried restarting the newly created VM and it worked with the 64bit iso. Not sure what the issue was, but thanks for the help. –  Csmarkus Jun 20 at 16:32
    
lol, good to know... just in case of some one reading comments: something similar happened to me at windows. I dind't chose a 64 bits version when creating a new VM (this only pre-configure for you) but meabie do something else our particular hw specs –  Quijote Shin Jun 20 at 16:35

First of all go to BIOS and check whether VT-x (Virtualization Technology) is enabled. Use Del key or F2 key when booting your PC. Then go to Advanced --> Processor Configuration --> Intel(R) Virtualization Technology and enable VT. Press F10 and save configuration and reboot PC.

Now check Virtualbox.

Thanks

share|improve this answer
    
I do have that enabled in my BIOS. One of the first things I did once I built the server. –  Csmarkus Jun 20 at 16:17

Not the answer you're looking for? Browse other questions tagged or ask your own question.