Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm trying to get a Tascam US-122L USB 2.0 Audio/MIDI Interface working with jackd.

The correct kernel modules seem to load when I plug the device in:

$ lsmod | grep us122l
snd_usb_us122l         23020  0 
snd_usbmidi_lib        29476  1 snd_usb_us122l
snd_hwdep              17709  2 snd_usb_us122l,snd_hda_codec
snd                    78957  18 snd_usb_us122l,snd_usbmidi_lib,snd_hda_codec_analog,snd_hda_intel,snd_hda_codec,snd_hwdep,snd_pcm,snd_rawmidi,snd_seq,snd_timer,snd_seq_device

ALSA seems to detect the card:

$ cat /proc/asound/cards
 0 [SB             ]: HDA-Intel - HDA ATI SB
                      HDA ATI SB at 0x60000000 irq 16
 1 [US122L         ]: USB US-122L - TASCAM US-122L
                      TASCAM US-122L (644:800e if 0 at 001/004)

Also:

$ aplay -L
default
    Playback/recording through the PulseAudio sound server
sysdefault:CARD=SB
    HDA ATI SB, AD198x Analog
    Default Audio Device
front:CARD=SB,DEV=0
    HDA ATI SB, AD198x Analog
    Front speakers
surround40:CARD=SB,DEV=0
    HDA ATI SB, AD198x Analog
    4.0 Surround output to Front and Rear speakers
surround41:CARD=SB,DEV=0
    HDA ATI SB, AD198x Analog
    4.1 Surround output to Front, Rear and Subwoofer speakers
surround50:CARD=SB,DEV=0
    HDA ATI SB, AD198x Analog
    5.0 Surround output to Front, Center and Rear speakers
surround51:CARD=SB,DEV=0
    HDA ATI SB, AD198x Analog
    5.1 Surround output to Front, Center, Rear and Subwoofer speakers
surround71:CARD=SB,DEV=0
    HDA ATI SB, AD198x Analog
    7.1 Surround output to Front, Center, Side, Rear and Woofer speakers
dmix:CARD=SB,DEV=0
    HDA ATI SB, AD198x Analog
    Direct sample mixing device
dsnoop:CARD=SB,DEV=0
    HDA ATI SB, AD198x Analog
    Direct sample snooping device
hw:CARD=SB,DEV=0
    HDA ATI SB, AD198x Analog
    Direct hardware device without any conversions
plughw:CARD=SB,DEV=0
    HDA ATI SB, AD198x Analog
    Hardware device with all software conversions
usb_stream:CARD=SB
    HDA ATI SB
usb_stream:CARD=US122L
    TASCAM US-122L

The card also shows up in qjackctl, but when I select it as interface and try to start jackd, I get the following error:

16:37:20.811 D-BUS: JACK server could not be started. Sorry
Cannot connect to server socket err = No such file or directory
Cannot connect to server socket
jack server is not running or cannot be started
Fri Jun 20 16:37:20 2014: Starting jack server...
Fri Jun 20 16:37:20 2014: JACK server starting in realtime mode with priority 10
Fri Jun 20 16:37:20 2014: control device hw:1
Fri Jun 20 16:37:20 2014: control device hw:1
Fri Jun 20 16:37:20 2014: Acquired audio card Audio1
Fri Jun 20 16:37:20 2014: creating alsa driver ... hw:1|hw:1|1024|2|44100|0|0|nomon|swmeter|-|32bit
Fri Jun 20 16:37:20 2014: control device hw:1
Fri Jun 20 16:37:20 2014: ERROR: ALSA: Cannot open PCM device alsa_pcm for playback. Falling back to capture-only mode
Fri Jun 20 16:37:20 2014: ERROR: Cannot initialize driver
Fri Jun 20 16:37:20 2014: ERROR: JackServer::Open() failed with -1
Fri Jun 20 16:37:20 2014: ERROR: Failed to open server
Fri Jun 20 16:37:21 2014: Saving settings to "/home/kraxor/.config/jack/conf.xml" ...
16:37:36.683 Could not connect to JACK server as client. - Overall operation failed. - Unable to connect to server. Please check the messages window for more info.
Cannot connect to server socket err = No such file or directory
Cannot connect to server socket
jack server is not running or cannot be started

Tried to modify /etc/security/limits.conf and ~/.asoundrc according to the answer to this question, but it didn't solve the problem. Currently they look like this:

$ cat .asoundrc | grep -v \#
pcm.!usb_stream {
        @args [ CARD ]
        @args.CARD {
                type string
                default "1"
        }

        type usb_stream

        card $CARD
}

ctl.!usb_stream {
        @args [ CARD ]
        @args.CARD {
                type string
                default "1"
        }

        type hw

        card $CARD
}


$ cat /etc/security/limits.conf | grep -v \#
@audio   -   rtpio     99
@audio   -   memlock   unlimited
@audio   -   nice      -10

The same happens with Xubuntu 14.04 and Ubuntu Studio 12.04.

Any suggestions are greatly appreciated. This card should be supported as far as I know.

share|improve this question

1 Answer 1

  • If Pulseaudio is running, you may have this problem.
    To stop it for testing, run 2 commands:
    echo autospawn=no > ~/.pulse/client.conf
    pulseaudio -k
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.