Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm brand new to Linux so I thought I'd give it a shot for my gaming pc I just built, however it says the wired connection is not connected.

When it is I really can't give out the terminal info Because it won't connect however when I ping my IP address in terminal it says unreachable and I’ve tried a couple of other things so yeah can someone please help.

I'm just debating on getting a wireless card but I'm not sure I'll have the same problems so if you can help thanks.

Edit fixes code tags

sudo lshw -c network *-network description: Ethernet interface product :rtl8111/8168/8411 pci express gigabit Ethernet controller vendor: Realtek semiconductor co.,ltd. physical id 0 bus info: pci@0000:01:00.0 logical name: eth0 version: 06 serial 74:d4:35:5a:67:98 size 10mbits/s capacity: 1gbit/s width: 64 bits clock:33mhz capabilities: pm msi pciexpress msix vpd bus_master cap_list Ethernet physical tp mii 10bt 10bt-fd 100bt 1000bt 10000bt-fd autonegotiation n=2.3lk-napi duplex=half firmware=rtl8168e-3_0.0.4 03/27/12 latency=0 link=no muliticast=yes port=MMI speed 10mbit/s resources: irq:42 ioport=e100 Ioport=e100 (size 256) memory:fea000000-fea00fff memory:d0000000-d0003ff

Ifconfif -a Eth0 Link encap: ether net hwaddr 74:d4:35:5a:67:98 Up broadcast multicast mtu:1500 metric:1 Rx packets:0 errors:0 dropped:0 overruns:0 frame:0 Tx packets:7 errors:0 dropped:0 overruns:0 carrier:0 Collisions:0 txqueuelen:1000 Rx bytes:0 (0.0 B) tx bytes:858 (858.0 B) Lo link encap:local loopback Inet addr:127.0.0.1 mask:255.0.0.0. Inet6 addr: ::1/128 scope:host Up loopback running mtu:65536 metric:1 Rx packets:32 errors:0 dropped:0 overruns:0 frame:0 Tx packets:32 errors:9 dropped:0 overruns:0 carrier:0 Collisions:0 txqueuelen:0 Rx bytes:2432 (2.4 Kb)tx bytes:2432 )2.4 kb)

`for netstat -rn Kernel ip routing table Destination Gateway genmask flags mss windows irtt iface For having the sudo dhclient -r then dhclient then the config showed Eth0 Link encap:Ethernet hwaddr 74:d4::35:5a:67:98 Up broadcast multi cast mtu:1500 metric:1 Rx packets:0 errors:0 dropped:0 overruns:0 frame:0 Tx packets:0 errors:0 dropped:0 overruns:0 carrier:0 Collisions:0 txqueuelen:1000 Rx bytes:0 (0.0 B) tx bytes:0 (0.0 B) lo Link encap: local loopback Inet addr:127.0.0.1 mask:255.0.0.0 Inet6 addr: ::1/128 scope:host Up loopback running mtu:65536 metric:1 Rx packets:133 errors:0 dropped:0 overruns:0 frame:0 Tx packets:133 errors:0 dropped:0 overruns:0 carrier:0 Collisions:0 txqueuelen:0 Rx Bytes:9505 (9.5 kb) tx bytes:9505 (9.5 Kb)

share|improve this question
    
I'm so sorry to waste your time @meccooll it was the cable I swapped it and now it is working –  user295141 Jun 24 at 3:50
    
Well that was a good exercise to troubleshoot it down to hardware. Feel free to accept bellow answer :) –  meccooll Jun 24 at 4:00

1 Answer 1

up vote 0 down vote accepted

Not hearing anything on the link (not receiving any packets) troubleshoot hardware, cables, router, network card...

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.