Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

==================================

UPDATE - 6/20 #tangodown

I went ahead and executed 'cp -rfp /home/OLD /home/NEW'

Now, I have some additional hidden folders in '/home/NEW', and it also has a new unhidden folder '/home/NEW/OLD'.

Now I have correct looking symlinks... 'Access-Your-Private-Data.desktop -> /usr/share/ecryptfs-utils/ecryptfs-mount-private.desktop' '.ecryptfs -> /home/.ecryptfs/OLD/.ecryptfs' '.Private -> /home/.ecryptfs/OLD/.Private' 'README.txt -> /usr/share/ecryptfs-utils/ecryptfs-mount-private.txt'

HERE IS WHERE I AM TODAY (6/20):

Computer boots up in from LiveUSB, and I can successfully find and recover the ecrypt home folder by using 'ecryptfs-recover-private'.

Computer does not bootup without LiveUSB, and instead of a login screen I get a blank screen with popup warning of Graphic Configuration issues, which lets me try to boot in low graphics mode, configure graphics, or look at system errors. This is new, since I last ran the ecryptfs-recover-private and it maxed out my hard drive, which I then had to delete data from (including removing root trash and cache.

Before i run ecryptfs-recover-private, I only have 33% free space while the recovery drive is still encrypted... and after I run ecryptfs-recover-private and start copying it over to the drive mounted at /media/ubuntu/123xyz, I get to 100% and the computer messages (FAIL) that I'm out of space.

It seems fine when it is mounted as read-only at /tmp/ecryptfs.123xyz, but when I start copying files, it runs our of space. Even if I do it incrementally, it seems the OS is not booting properly.

Now, I seem to have enough space to work on from LiveUSB, but it is acting slow and funky.

Here is output from root@ubuntu: /my_folder # df -h:

**Filesystem             Size  Used  Avail Use% Mounted on**
/cow                     976M  150M  776M  17% /
udev                     1.5G  4.0K  1.5G   1% /dev
tmpfs                    303M  1.1M  301M   1% /run
/dev/sdb1                3.8G  2.0G  1.9G  52% /cdrom
none                     4.0K     0  4.0K   0% /sys/fs/cgroup
tmpfs                    1.5G  1.1M  1.5G   1% /tmp
none                     5.0M  4.0K  5.0M   1% /run/lock
none                     1.5G   80K  1.5G   1% /run/shm
none                     100M   36K  100M   1% /run/user
/dev/mapper/ubuntu-root   73G   46G   24G  67% /media/ubuntu/123xyz

With the new files coming to the drive at roughly 30+GBs, and the original /media/ubuntu/123xyz/.ecryptfs backup file weighing in at at 29GBs, I easily outgrow my 79GBs worth of available space.

I tried using my external drive (ugh, the stupid WD Passport), which is locked and encrypted and needs a Mac to unlock (not available right now), I am dealing with how to get my drive back to where it was...40% or so left of free space and all recovered.

THANK YOU.

ORIGIN

I am not a novice, but clearly not learned enough to fix this damaging issue I just created, so thanks in advance for your help...

This is a recent, customized infosec/dev ubuntu 14.04 LTS laptop, running sweet until the below happened.

  1. I followed these instructions to a tee in order to change my old username into a new one: http://www.cyberciti.biz/faq/howto-change-rename-user-name-id

  2. I also continued with specific home directory intsructions found here: http://jesin.tk/change-home-directory-in-linux/)...

Now my username, group and home folder are all changed and permissions/ownership correct, as well as new user has been set to new home. I even ran the cp -f /home/username/* /home/new_home_dir/ to copy over all home files to new folder. However, this didn't work so well in my favor...

PROBLEM

I can login, I can access files in home, but ALL of my desktop, settings and home files are gone. Back to square 1, with only 1 clue in my new home folder: two files by the name of README and Access-Your-Private-Data.desktop.

Problem Key:

Old username: OLD

New username: NEW

New group: NEWG1

My User ID Info:

uid=1000(NEW) gid=1000(NEWG1) groups=1000(NEWG1),4(adm),24(cdrom),27(sudo),30(dip),46(plugdev),107(lpadmin),124(sambashare)

UID 1000 has not changed even though the username changed. OLD was the user 1000, as was OLD the home directory name. I changed the username to NEW, same UID (1000), and changed OLD group name to NEWG1.

I did all of this from command line, by hitting Ctrl+Alt+F1 from the login screen, then logging into a secondary account (not the OLD or the NEW account).

ORIGINAL ISSUE:

Now, I can login all day long. However, my OLD account, which has been changed to NEW, looks like a brand new user account, and all of my data and files and configuration are gone when logged in using the NEW account. However, in the /home/NEW folder, I have these files:

Access-Your-Private-Data.desktop
README.txt

But no files such as:

.ecryptfs
.private
...etc

When trying to open Access-Your-Private-Data.desktop, terminal opens and closes instantly. So nothing happens. And when executing ecryptfs-mount-private I get the following;

$ ecryptfs-mount-private
ERROR: Encrypted private directory is not setup properly

QUESTIONS (SOLVED - SEE BELOW):

  • (SOLVED - SEE UPDATE BELOW) How do I access the encrypted files and move, delete or alter them?
  • (SOLVED - SEE UPDATE BELOW)Where did all of my home files and config from OLD user go, if all
  • (SOLVED - SEE UPDATE BELOW)I did was change the username and group name, as well as home folder name (and even assign user to folder), and copy everything?
  • (SOLVED - SEE UPDATE BELOW)If it's not encrypted, where did it all go?
  • Can I keep going and get it fixed with NEW everything?
  • Or, Can I backtrack properly to OLD everything?

I looked in /tmp but nothing like 'ecryptfs.123XYZ' is in there except ssh-123XYZ and hsperfdata_NEW.

This guys made it look easy on what to do with the file: hgoshawknest.wordpress.com/2010/04/16/how-to-recover-crypted-home-directory-in-ubuntu/

But again, this is not working for me.

STEPS I TOOK:

I am setting up a boot USB with Ubuntu 14, in hopes to follow directions on mounting properly (as in described here: ubuntuforums.org/showthread.php?t=1810825), but I am not sure I am working correctly.

Thanks in advance. This is amazingly important to recover my old setup, regardless of username and home folder name.

Please help with this if you can.

All the best!

PS - Here is a list of references that helped me screw up (I mean execute) the above:

RESOURCES:

  1. www.hgoshawknest.wordpress.com/2010/04/16/how-to-recover-crypted-home-directory-in-ubuntu/
  2. www.cyberciti.biz/faq/howto-change-rename-user-name-id/
  3. www.jesin.tk/change-home-directory-in-linux/
  4. www.ubuntututorials.com/change-username-ubuntu-12-04/
  5. www.ubuntuforums.org/showthread.php?t=2103420
  6. www.askubuntu.com/questions/34074/how-do-i-change-my-username
  7. www.bodhizazen.net/Tutorials/Ecryptfs#Live
  8. www.bugs.launchpad.net/ubuntu/+source/ecryptfs-utils/+bug/1028532
  9. www.askubuntu.com/questions/190404/changed-username-now-i-cannot-log-on-or-view-my-previous-files
  10. www.manpages.ubuntu.com/manpages/jaunty/man8/usermod.8.html
share|improve this question
    
Well, encryption is the wild card here. Copy ALL your files from your OLD to NEW directory. cp -R /home/OLD/*.* /home/NEW/ –  bodhi.zazen Jun 19 at 19:13
    
Thanks Benoit.I went ahead and executed 'cp -rfp /home/OLD /home/NEW' ... NICE catch. Now, I have some additional hidden folders in '/home/NEW', and it also has a new unhidden folder '/home/NEW/OLD'. Cool, huh. Now I have correct looking symlinks... 'Access-Your-Private-Data.desktop -> /usr/share/ecryptfs-utils/ecryptfs-mount-private.desktop' '.ecryptfs -> /home/.ecryptfs/OLD/.ecryptfs' '.Private -> /home/.ecryptfs/OLD/.Private' 'README.txt -> /usr/share/ecryptfs-utils/ecryptfs-mount-private.txt' So I'm going to try and recover now from encrypted disk...stay tuned and thanks! –  maddhatter Jun 19 at 19:20
    
Welcome to Ask Ubuntu! The best way to add additional information to your question is by editing it, with the edit button. It is better visible that way, and comments are mainly for secondary, temporary purposes. Comments are removed under a variety of circumstances. Anything important to your question should be in the question itself. –  guntbert Jun 20 at 18:40

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.