Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've been trying to setup Ubuntu 14.04 (64bit) along with my Win 8.1 Desktop-PC. My Problem is, that I have UEFI instead of the normal BIOS. When I just install Ubuntu as I did very often on other machines, and start my PC, it boots right into Windows without entering GRUB. Well, after some research, I figured out, that I have to switch off secure boot in my UEFI. I found the following instructions.

Guide To Install Ubuntu 14.04 In Dual Boot Mode With Windows 8 Or 8.1 UEFI

and

How To Disable UEFI Secure Boot In Windows 8 & 8.1

On the second link, there is a point, where I am supposed to enter the UEFI-Firmware-Settings via Windows. The problem is, my Windows doesn't show this option. When I boot straight into UEFI, there isn't an option for secure boot or no equivalent either.

I am using an ASUS motherboard. My UEFI looks like this.

share|improve this question
    
You might want to take a look at this: askubuntu.com/questions/484895/… Thank you! –  Raphael Jun 18 at 19:23
1  
Your problem is unrelated to secure boot. As you boot, you have to select which OS to boot in your BIOS. Every bios is a bit different, but you have a UEIf boot option in the security to boot section, boot ubuntu rather then windows and you will get a grub screen. –  bodhi.zazen Jun 18 at 19:55
    
@Raphael The OP wants to get UEFI booting to work und you give legacy MBR instructions. UEFI booting is easy when done right. Stop spamming UEFI topics with legacy answers. It's 2014. –  LiveWireBT Jun 19 at 6:04
    
Tx Raphael, that link saved me a night. –  user3305585 Jun 19 at 7:00

1 Answer 1

Enter the Advanced Mode and go to Boot. It should look similar to this:

enter image description here enter image description here enter image description here

Here you can disable or enable Fast Boot and other UEFI Booting releated options if needed.

If you installed Ubuntu correctly, there should be an entry called ubuntu. Try to boot that via boot override. If that works, you just need to configure the boot order properly.

If there is no such entry or similar, you probably have to either reinstall Ubuntu, register the bootloader via efibootmgr from a live media or install a default UEFI bootloader like gummiboot.

I currently have one UEFI machine with an Asus motherboard at home (I had 2 a few months back). So it's possible, but I just can't reboot it now to make screenshots of my settings. Anyway hope this helps you. Getting Ubuntu to boot with UEFI isn't difficult.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.