Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I tried a few things already. this is my /etc/default screen. This wont work. It still brings me to the grub screen and stays there until an OS is selected. I don't want that screen to come up. I want to go straight into windows 7. Any info would be nice.

# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.

GRUB_DEFAULT="Windows 7 (loader) (on /dev/sda3)"
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`

# Uncomment to disable graphical terminal (grub-pc only)

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux

# Uncomment to disable generation of recovery mode menu entries

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"
share|improve this question
You also may set time to 1 sec so then system should boot quickly ;) – g1b3r Jun 18 '14 at 18:06
up vote 1 down vote accepted

To hide the GRUB OS selection screen modify:


And after you save and close run:

sudo update-grub

To permanently delete GRUB use a Windows 7 bootable DVD like this:

  • when you see the install screen choose the Repair your computer option
  • select Command Prompt option
  • write these commands: bootrec /fixmbr and bootrec /fixboot
  • restart your PC

You will lose the ability to boot into Linux. You'll have to use a Linux live CD to repair GRUB if you want Linux back!

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.