Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I was having problems installing MongoDB with NPM and I found someone saying that the problem is related to the fact that I had Python 2 and 3 installed. So I removed Python 3 and after this many Ubuntu apps disappeared.

After rebooting, Unity stopped working and I can't open terminal, view my apps, etc.

I've reinstalled unity and also tried to install gnome, but it still doesn't work.

What do I have to do?

share|improve this question
    
i recommend you to switch to GNOME environment from unity as the same problem was faced by me to and i got away from it by downloading gnome version of 14.04 you can download it from wiki.ubuntu.com/UbuntuGNOME/GetUbuntuGNOME –  agha rehan abbas Jun 18 at 9:40
    
I've seen several options to solve the problem. In my case the Unity plugin being disabled was the problem: askubuntu.com/questions/453482/… I solved it in this way: askubuntu.com/questions/453482/… –  Damian Nadales Jun 18 at 9:51
    
I already have compizconfig manager and tried to run ccsm but it throwing an error (I'll check the error message when I get home to add to the question). –  Juliano Nunes Silva Oliveira Jun 18 at 10:11
    
Try this answer to a similar question that happened while running Ubuntu 13.04: askubuntu.com/questions/384033/… –  karel Jun 18 at 10:16
    
This happened to me to, what I ended up doing is reinstalling Unity and Gnome from the shell and running an open command for showing the desktop. I had a friend walk me through it and don't remember much, but I hope it helps. –  user294627 Jun 18 at 10:21

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.