Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.
  1. I am almost new to Ubuntu 14.04 (64 bits, in my case) so I only know the Unity interface and a bit of Gnome from previous Ubuntu experience. As the new version of KDE looked promising, I installed kde-desktop thinking I would automatically get whatever display manager allowing me to choose between KDE and Unity at boot time.

  2. Unfortunately no display manager ever showed up (nor even by clicking on the small icon supposed to do that at login time, which looked dead) and I seemed to be stuck on KDE (very nice, but totally unfamiliar to me, so while I am learning to tune KDE, I just HAVE to go on with my normal work for at least some months with Unity).

  3. Reinstalling ubuntu-desktop made things even worse : automatic login gives me a black screen. Of coures, I can still kill the server from a text console and issue a startx, from whick I seem to get Gnome, but not Unity :-(

Does somebody know if my system is now hopelessly messed up ? I have a LOT of things which were installed on my system (64 GB on my / SSD, /home is elsewhere) ?

Also is there something somewhere explaining how to make Unity and KDE coexist on the system and be chosen at session start time, at least until I know them both enough to be able to make an enlightened choice ? I remember it was possible with some former versions of Ubuntu, though KDE did not seem easy enough to master at the time.

Any kdm, lightdm or gdm guru here ? (I tried to reconfigure them and choose one different each time, without any more success). By the way, I had an autologin previously and did not know how to remove it. Might that be part of the problem?

Thanks to whoever has or may have a clue. There is clearly something I am not grasping clearly :-/

share|improve this question
    
Do you completely uninstall kde? –  Raphael Jun 18 at 5:49
    
No, because I would like to be able to keep whatever I customized in KDE (and which is in a .kde or .kde-config, I guess) quietly waiting while I switch back to Unity in a later session for my normal work, in order to (hopefully) resume my discovery of KDE later in a future session. –  user294557 aka Paganel Jun 18 at 5:54

1 Answer 1

Probably it would be easier for you to disable autologin first and then check how you choose different desktops at the login screen.

  1. To disable auto login open

    Settings -> User Accounts

or in terminal (ALT+CTRL+T) run

unity-control-center user-accounts

and turn it off

enter image description here

  1. To install KDE run

    sudo apt-get install kde-plasma-desktop

  2. Log out and choose Desktop

enter image description here

share|improve this answer
    
Thanks, Steve ! Looks like EXACTLY what I was/am aiming for ! :-) But unfortunately I have no "Settings" available in my present system state "A": NO Unity vertical bar, NO Gnome horizontal top menu, just my old desktop without controls, plus the ability to issue Alt-Crtl-T to get a terminal. Is there a way to manage from there to remove that autologin or get the "Settings" menu ? For some unknown reason, I just have a gray graphic screen without anything on it except the mouse pointer when I boot. I have to start a console session (Alt-Ctrl-F1) stop X and issue a startx even to get to "A". –  user294557 aka Paganel Jun 18 at 8:12
    
In case it might help, here is my /etc/lightdm/lightdm.conf (sorry, new-lines disappear below) : [SeatDefaults] autologin-guest=false autologin-user=fda autologin-user-timeout=0 autologin-session=lightdm-autologin greeter-session=unity-greeter user-session=ubuntu –  user294557 aka Paganel Jun 18 at 8:17
    
Some additional information, just in case : 1) I have both /tmp and /var/log in a tmpfs (because my system is on a SSD) 2) I did install ubutustudio and I do not know whether in might interfere –  user294557 aka Paganel Jun 18 at 8:39
    
In terminal try to run unity-control-center user-accounts –  Ruslan Gerasimov Jun 18 at 8:47
    
Thanks. I got that : fda@S830-256-U14:~$ unity-control-center user-accounts ERROR: [/home/fda/.ecryptfs] does not exist ERROR: Configuration invalid ERROR: [/home/fda/.ecryptfs] does not exist ERROR: Configuration invalid ERROR: [/home/fda/.ecryptfs] does not exist ERROR: Configuration invalid ERROR: [/home/fda/.ecryptfs] does not exist ERROR: Configuration invalid ERROR: [/home/fda/.ecryptfs] does not exist ERROR: Configuration invalid ERROR: [/home/fda/.ecryptfs] does not exist ERROR: Configuration invalid but after that the window, and I discovered the autologin was in fact to 0. (!!??) –  user294557 aka Paganel Jun 18 at 8:52

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.