Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am trying to install Stack Applet. I followed the instructions in this question. To be specific I used the following

sudo add-apt-repository ppa:george-edison55/george-edison
sudo apt-get update
sudo apt-get upgrade
sudo apt-get install stackapplet
python /usr/share/stackapplet/ &

When I start Stack Applet via the Dash, nothing happens. (i.e. no window opens.) I tried restarting my computer and starting Stack Applet but that also did not work. How do I install Stack Applet?

EDIT: I tried using Ubuntu Software center with no luck. My interface looks like soscreenshot

share|improve this question
Have you tried this method of installation… – Raphael Jun 17 '14 at 18:27
@Raphael No, as there is not a Trusty version. (I'm running 14.04) Which should I download? The most recent version? – Cammy_the_block Jun 17 '14 at 18:34
Then maybe it is not supported in 14.04 – Raphael Jun 17 '14 at 18:36
Hmm, I wonder if anyone else got it to work. – Cammy_the_block Jun 17 '14 at 18:38
There is nothing wrong with this question here, and I really don't think it is on topic on stack apps. – Seth Jun 18 '14 at 12:54
up vote 9 down vote accepted

I'm the author of StackApplet, so hopefully I can help shed some light on what's going on here.

First of all, the version in the Software Center is currently broken. This is because Stack Exchange recently shut down version 1.x of their public API (which StackApplet used). Right before this happened, I updated the source code and release StackApplet 1.5.2, which I have tested and can confirm works on Ubuntu 14.04.

Secondly, the new version is available in a PPA, but not the one you included in your question. You need to add the following PPA to your system:


After installation, you can confirm that you have the correct version installed by using:

dpkg -s stackapplet | grep Version

After this is complete, you should be able to run the application directly from the dash.

Edit: you may also be missing the python-appindicator package. You can make sure it is installed by running the following command in a terminal:

sudo apt-get install python-appindicator
share|improve this answer
Looked really promising. Didn't turn out so, same re I installed via sudo add-apt-repository ppa:stackapplet-dev/stackapplet, sudo apt-get update, sudo apt-get upgrade, andsudo apt-get install stackapplet. dpkg -s stackapplet | grep Version returned Version: 1.5.2-0~201405081543~ubuntu14.04.1 – Cammy_the_block Jun 19 '14 at 3:08
@Cammy_the_block: This may be a long shot, but please try closing StackApplet, opening a terminal, running sudo apt-get install python-appindicator, and then starting StackApplet again. – Nathan Osman Jun 19 '14 at 3:29
It is now installed! However, I'm facing the same issue as this guy. – Cammy_the_block Jun 19 '14 at 4:45
@Cammy_the_block: I've answered that question. – Nathan Osman Jun 19 '14 at 5:05
May I suggest python-appindicator be added as a dependency so that people don't have to ask this question? – Cammy_the_block Jun 19 '14 at 6:40

I recommend you to uninstall your original install of Stack Applet. Then, reinstall it using the Ubuntu Software Center as it is very easy and it worked perfectly for me. I did so in Ubuntu 14.04. enter image description here

*edit enter image description here

share|improve this answer
Did you do so in 14.04? Also, did you add the PPA first? – Cammy_the_block Jun 17 '14 at 18:40
no i just clicked on the install button in sofware centre – agha rehan abbas Jun 17 '14 at 18:41
I'm still installing, as I have a slow computer, sorry. – Cammy_the_block Jun 17 '14 at 18:57
ok take your time – agha rehan abbas Jun 17 '14 at 18:58
i cant do anything more than this no idea about i it i give up sorry – agha rehan abbas Jun 17 '14 at 19:49

I installed the latest version via ppa:stackapplet-dev/stackapplet as advised, just to find out the problem still resides in the code as I am writing this. A quick check shows the core of the problem you (and I) are experiencing: stackapplet is failing to authorize via the following URL: … 4&_=1 …

The call results in a 404 - Not Found.

Until @nathan-osman (the author) fixes this, or someone else steps in to do the job, there is little hope in being able to use StackApplet.

For informational purposes, here’s a screenshot showing the 404…

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.