Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

My pc shows hidden files even after renaming the file with a name which starts with a dot is there any solution for this.

share|improve this question
What have you tried? Do they show up in the terminal using ls? What happens if you press ctrl+h? – dan08 Jun 17 '14 at 17:49
did you rename the file via menu -> rename or using mv command in terminal? Please edit your question, to add more information, regarding your OS and if hidden files/dot-files are always visible in nautilus. Also try Ctrl+H, to toggle hidden files [on] and [off] – v2r Jun 17 '14 at 17:49
yes exactly i have used hiding them via renaming them satrting with dot and pressed ctrl+h and the file disappears but it appears again when i reopen nautilus and again i should type ctrl+h to hide them – agha rehan abbas Jun 17 '14 at 17:51
isnt there any permanent solution for this – agha rehan abbas Jun 17 '14 at 17:52
mvcommand stands for move/rename and can be used like this: mv ~/Desktop/testfile.txt ~/Desktop/.testfile.txt. This way you rename/ your file from testfile.txt to .testfile.txt. – v2r Jun 17 '14 at 18:01
up vote 6 down vote accepted

Ctrl+H Should toggle whether hidden files are visible.

To permanently change the setting in nautlius go

Edit > Preferences > Views

enter image description here

And turn off: Show hidden and backup files

share|improve this answer

Create an empty documents rename it .hidden. Open it (Mousepad for xubuntu). Type the folder name you want to hide. I have attached a picture. Here $RECYCLE.BIN and System Volume Information are hidden. So I type the name in .hidden file and put it in the folder where this two folders are currently in that I want to hide. After that hide the folders by CTRL+H. Good luck.

enter image description here

share|improve this answer
You welcome bro.. :) – rashed azad Jun 17 '14 at 18:08

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.