Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Earlier today I finished an apt-get upgrade and my machine reported that it needed to be rebooted. So I shut everything down and rebooted the box. The shutdown didn't go as smoothly as I would like and I ended up having to do a hard reset.

But the machine then proceeded to come back up normally. I got the lightdm login screen with my background. When I attempted to login however strange things happened. Initially nothing worked, I saw the background but that was it.

From a different machine I was able to log in and tried rebooting again and when it came back up and I attempted to log in I got my background with nothing else.

I've been searching the Internet for the last few hours trying to figure something out but to little avail. I have tried

sudo service lightdm stop
rm -f  ~/.config/nux/dconf/
sudo reboot

sudo apt-get install gnome-session-fallback

Logged in using the fallback gnome environment which works but most of my applications like adjusting background etc. do not. I also tried installing cinnamon but that has proved to be a no go as it crashes immediately upon logging in.

The Gnome-session-fallback has at least provided a destop environment I can work with. But now when I try to log into Unity I get a black screen with nothing but a mouse pointer. Which is semi functional (i.e. it moves) but that's all.

I'm a little lost as to what to attempt next. I'd like to go back to using unity if anyone can suggest a way to do that.

share|improve this question
    
The easiest solution would be to backup data and reinstall OS. –  Registered User Jun 17 at 14:47
    
Can you install lubuntu/xubuntu and login with that? –  Tim Jun 17 at 16:55

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.