Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

My keyboard has media keys and they work globally on Unity with Banshee but don't with VLC when another app is focused. How to fix that?

share|improve this question

5 Answers 5

up vote 14 down vote accepted

I had a similar problem and the issue was that Gnome would capture the media keys before they reached VLC, to fix this you can go to "System->Preferences->Keyboard Shortcuts"

There you will see a header called sound (Expand it if needed), and remove the key combinations you want in VLC from there (You can disable them by clicking on the item and then pressing backspace).

Only problem with this is that any other applications that do use Gnome's built-in handling won't work anymore with the media keys, unless you add them again (Which in turn breaks VLC again)

share|improve this answer
    
I don't know why, but I had also to restart the computer to make it recognize global keys, –  Jader Dias Jun 12 '11 at 18:29
1  
For me it was enough to restart VLC. –  Bombe Apr 21 '13 at 20:28

Here is an updated answer for Ubuntu 13.10 using VLC media player 2.0.8:

In Ubuntu, go to System Settings > Keyboard > Shortcuts > Sound and Media

Disable the key combinations you want in VLC (by clicking on the item and pressing backspace).

In VLC, go to Tools > Preferences > Hotkeys

Set the key combinations you previously disabled to a VLC action in a Global.

You can then set back the keyboard shortcut for the Ubuntu System in order for the other applications that do use Gnome's built-in handling to work. However, when VLC is running, VLC will take precedence over other applications.

EDIT: you may also need to relaunch VLC for the new hotkeys to be updated.

share|improve this answer

I got it working by downloading hotkeys in the software centre. I search hotkeys in the software centre and it shows up. It says is A hotkeys daemon for your Internet/multimedia keyboard in X.

First I download it, and than I had to disable the system hotkeys, than set the hotkeys in VLC, finally I enable the system's hotkeys. I can pause, play, and skip with the keyboard even with VLC minimize.

share|improve this answer
1  
@salip, Can you please add the steps or a screenshot and help us understand better. –  devav2 Nov 9 '12 at 18:58

The only workaround I could think of is to add a key modifier, e.g. press an Alt while pressing the multimedia key. That way the key combination is different from what's captured by GNOME thus it simulates the effect of using multimedia key to control VLC.

I used this only for play/pause (So the key is Alt+XF86AudioPlay, something like this; in VLC it shows as Alt+"Media Play Pause").

share|improve this answer

VLC comes with configurable hotkey definitions. To access the hotkey menu open Tools -> Preferences -> Hotkeys:

enter image description here

The key for a given action can be determined by clicking on the line in between Clear and Apply. Then a window pops up to ask you for the new key combination. Press Apply to save these.

This procedure works fine with standard keyboard keys. However depending on keyboard hardware layout multimedia keys may not be recognized correctly (bug #419795, Videolan Support, Videolan on Ubuntu 10.10)

share|improve this answer
1  
Unfortunately that won’t be enough while GNOME still intercepts those keys. You need to disable them in the system settings. –  Bombe Apr 21 '13 at 20:29

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.