Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

The wallpaper of my desktop doesn't appear and instead only the wallpaper of my login screen appears in my desktop. Also though the launcher, panel everything appears(as shown in the screen shot) they work as well. I tweaked my settings with ubuntu-tweak and everything went haywire after that. I have even deleted ubuntu-tweak after that yet the issue persists.

I've read this article on UbuntuForums but still don't understand.

Someone please explain it to me.

here's the screen shot from my desktop, http://goo.gl/L8sQly (sorry i can't post image here, because my reputation is to low)

share|improve this question

2 Answers 2

up vote 1 down vote accepted

Its just a simple solution but confusing problem LOL

Here's the solution:-

  • Open ubuntu-tweak.


enter image description here


  • Then go to Desktop icons in the Desktop section found under the Tweaks tab.


enter image description here


  • Make sure "Show desktop icons" is ON.


enter image description here


Done!

The problem can be understood if one could take a closer look at the last screen shot. There, under "Show desktop icons" it is clearly mentioned:-

Note: switch off this option will make the desktop unclickable

Since I had switched it OFF (as it is said above)my desktop was unclickable and as its ON now everything is fine!

share|improve this answer

I am able to think of several solutions to your issue. Try these and comment which one actually works below(or even if none of them works.)

The solutions here are in no particular order. That is it doesn't mean that Solution 1 has a higher chance of solving this issue than Solution 2.

Solution 1 - Tweaking unity:-

1- You must try resetting unity. For this make sure you have Unity Tweak tool. To install Unity Tweak tool, connect to the internet, open a terminal(with Ctrl+Alt+t) and type the following commands one by one:-

sudo add-apt-repository ppa:freyja-dev/unity-tweak-tool-daily
sudo apt-get update
sudo apt-get install unity-tweak-tool

After installing Unity Tweak tool with the above commands type this:-

unity-tweak-tool --reset-unity

This will reset unity.

Refer to this question's answers for more information on resetting unity.(Credits for this solution goes to that question's answers.)

2- If that doesn't work you might want to try uninstalling and reinstalling unity. For this(exercise caution) and type in your terminal:-

sudo apt-get remove unity
sudo apt-get install unity

Solution 2 - Tweaking LightDM:-

1- 50-ubuntu.conf is the equivalent of the famous lightdm.conf in Ubuntu 14.04. First check if there is something wrong with that file. Open it with this command:-

sudo gedit /usr/share/lightdm/lightdm.conf.d/50-ubuntu.conf

See if the file is something like this:-

[SeatDefaults]
user-session=ubuntu

If it is so, then leave it as it is. If it is not so then edit it to look like it is shown above.

2- Now if 50-ubuntu.conf is all right and still the issue persists then try reconfiguring it. For this use:-

sudo dpkg-reconfigure lightdm

Also try(if reconfiguring doesn't work):-

sudo stop lightdm
sudo start lightdm

3- If 1. and 2. don't work then try uninstalling and reinstalling LightDM. For this use the following commands:-

sudo apt-get remove lightdm* --purge
sudo reboot
sudo apt-get install lightdm* 

Credits to this and this.

Solution 3 - Checking the ownership of .Xauthority file :-

Sometimes the .Xauthority file's ownership changes to root causing a lot of issues. So check if it has root permissions. If it does have root permissions then change its permissions with the following command:-

sudo chown $USER:$USER ~/.Xauthority

Here the first $USER represents you as a user(is an environment variable set on boot and represents the user logged in) and the second one represents your group(the name of your group is same as your username, so can reuse the variable).

Refer to man chown for more info.

  • (This is an extract from the answer here)

By the way, if the .Xauthority file's ownership is not root then try this(exercise caution when trying to do this):-

sudo cp ~/.Xauthority /user/bin  #Just to have a backup of .Xauthority in a secure directory.
rm ~/.Xauthority

Note:-

Before you use Configuration tools(like ubuntu-tweak) you must always understand that there are high chances that things can get quite messed up. That is why many configuration tools(like ubuntu-tweak) are not included in the universe repository. So be a bit careful when you use Configuration tools from next time.

Also note that most of the solutions above are not so safe! They might mess up things a bit! So I would suggest you backup all your data before trying them.(The solutions are 'not-so-safe' as you messed up with a 'not-so-safe' Configuration tool as I have explained above! ;-D )

share|improve this answer
    
Try this too. –  Venki Jun 17 at 5:03
    
thanks Venki for helping me! i've found the solution :) –  ifarobi Jun 17 at 12:42
    
@ifarobi You have posted an answer by which you have actually solved your issue. Now I request you accept that answer after 48 hours from the time of posting your answer, so that the community will know your issue is actually solved(for you atleast). –  Venki Jun 17 at 13:35
    
okay need 4 hours again to accept @Venki –  ifarobi Jun 18 at 2:55

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.