Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a dual boot ubuntu and windows 8. Ubuntu is default os to start up and countdown select the default os to boot If I don't change that before. When I order between ubuntu and windows 8 countdown automatically hide and then, I have to press enter to boot from any highlighted os without time limit.My question is: How can I disable countdown for always and I select which os starts up with using up/down arrow key myself and until I don't select and don't pressing enter, that freeze on grub menu. Any ideas would be my pleasure

Note: There is no /etc/default/grub file in my ubuntu.

Edit: I reinstalled grub (sudo apt-get --reinstall install grub2 grub-pc) and now i have a/etc/default/grub file but the countdown did not stop with this changes:

# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.
# For full documentation of the options in this file, see:
#   info -f grub -n 'Simple configuration'

GRUB_DEFAULT=0
GRUB_HIDDEN_TIMEOUT=0
GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_TIMEOUT="-1"
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX=""

# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
#GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
#GRUB_GFXMODE=640x480

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
#GRUB_DISABLE_RECOVERY="true"

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"

I delete double quote GRUB_TIMEOUT="-1" around -1 which is automatically added to it and save then running sudo update-grub I get the following warning:

Warning: Setting GRUB_TIMEOUT to a non-zero value when 
         GRUB_HIDDEN_TIMEOUT is set is no longer supporte
share|improve this question

marked as duplicate by Eric Carvalho, bain, Danatela, bodhi.zazen, Seth Jun 20 at 0:37

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

    
Look at this There was no /etc/default/grub file –  TuKsn Jun 15 at 17:45
    
@Tuknutx I don't have /etc/default/grub file but I have /boot/grub/grub.cfg and in the second line I read # DO NOT EDIT THIS FILE. –  KasiyA Jun 15 at 18:09
    
@Tuknutx I follow @Null Pointer answer and install commented command the file /etc/default/grub fixed And change GRUB_TIMEOUT=-1 and then sudo update_grub but still countdown. –  KasiyA Jun 15 at 18:26
1  
You don't have to double quote -1! –  Null pointer Jun 15 at 18:45
1  
You can try to comment out the following two lines to # GRUB_HIDDEN_TIMEOUT=0 # GRUB_HIDDEN_TIMEOUT_QUIET=true then set GRUB_TIMEOUT=-1 then sudo update-grub –  TuKsn Jun 15 at 19:26

3 Answers 3

up vote 2 down vote accepted

To get grub file in /etc/default/grub

sudo apt-get install grub2 grub-pc

Then run

sudo update-grub

Now open /etc/default/grub using your favourite editor.

(you may need sudo permissions!)

And set this field to -1 to wait indefinitely!

GRUB_TIMEOUT=-1

You can try to comment out the following two lines to

# GRUB_HIDDEN_TIMEOUT=0 
# GRUB_HIDDEN_TIMEOUT_QUIET=true 

Now again run

sudo update-grub

and you are done! Hope this helps!

share|improve this answer
    
Please read my comment I have not /etc/default/grub in my ubuntu. –  KasiyA Jun 15 at 17:54
    
If you don't have this file then Try this sudo apt-get --reinstall install grub2 grub-pc –  Null pointer Jun 15 at 17:55

You can do this graphically with Grub-customizer, and the instructions for installing that program are located in the Ubuntu forums at http://ubuntuforums.org/showthread.php?t=1664134

share|improve this answer

Perhaps you have an EFI system, and grub is on the EFI partition. Hopefully mounted for you under Files->computer->/boot/efi, on my system grub.cfg is in /boot/grub .

No idea if the solutions posted so far would work for that.

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.