Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

How do I stop windows from maximizing when dragging them into a corner? I'm guessing this is a compiz feature but I'm not finding it in ccsm. I've turned off unity so it shouldn't be that. I'm running Natty.

share|improve this question
    
possible duplicate of How to keep programs from launching maximized? –  Takkat Jun 12 '11 at 15:18
add comment

3 Answers 3

up vote 6 down vote accepted

To change the windows behaviour you need to install and run Compiz Config Settings Manager ccsm Install ccsm.

Warning: ccsm can lead to unwanted effects that may be hard to overcome and may leave you without a desktop (see also this question for more background information).

Choose Grid from Window Management:

enter image description here

and adapt the window's grid behaviour to your needs:

enter image description here

share|improve this answer
add comment

It's the grid plugin in ccsm, deactivating it removes this feature. Or there are options to make it not maximise when dragging to the top but it will still fill one side of the screen when you drag it to that side.

share|improve this answer
add comment

Just disabling the grid in the Compiz manager did not solve this for me.

I also had to use gconf-editor to un-check: / -> desktop -> cinnamon -> windows -> edge_tiling

After that, windows no longer were snapping to full-screen.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.