Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Whenever I am trying to get the update I am getting the error at the last line:

Ign trusty-updates/multiverse Translation-en_IN
Ign trusty-updates/restricted Translation-en_IN
Ign trusty-updates/universe Translation-en_IN
Ign trusty-backports/main Translation-en_IN
Ign trusty-backports/multiverse Translation-en_IN
Ign trusty-backports/restricted Translation-en_IN
Ign trusty-backports/universe Translation-en_IN
E: dpkg was interrupted, you must manually run 'sudo dpkg --configure -a' to correct the problem.

And then according to the prompted error when I run:

$ sudo dpkg --configure -a
dpkg: error: parsing file '/var/lib/dpkg/updates/0009' near line 0:
 newline in field name `#padding'

What now? Can I get out of the error?

I tried this link.

share|improve this question
up vote 33 down vote accepted

You referred a wrong link. Try the below commands on terminal to remove all the files inside /var/lib/dpkg/updates directory ,

cd /var/lib/dpkg/updates
sudo rm *

And then run the below command to get newer ones,

sudo apt-get update
share|improve this answer
it works fine for me . – user284303 Jun 15 '14 at 13:33
This worked for me on Raspbmc/Raspbian as well. However, I'm curious - is this a safe solution? – aalaap Feb 17 '15 at 8:06
this worked for me on Ubuntu 12.04.5 LTS – chicks Jan 6 at 21:43
Still works in 2016 for ubuntu-15.04(-based Zorin OS 10)! – ThisNameBetterBeAvailable Jan 20 at 14:00

It works for me! I was trying to install the wireless driver when this error came. Had to delete the files and also the lock files.

sudo rm /var/lib/apt/lists/lock
sudo rm /var/cache/apt/archives/lock
cd /var/lib/dpkg/updates
sudo rm *
sudo apt-get update

and then you can run your apt-get install to whatever package you want to install

share|improve this answer
Not necessarily a good idea without extra precautions. – 0xC0000022L Jul 19 '14 at 5:59

protected by Community Mar 14 '15 at 22:45

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.