Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

i am new on ubuntu whenever i am trying to get the update i am getting the error at last

Ign http://in.archive.ubuntu.com trusty-updates/multiverse Translation-en_IN
Ign http://in.archive.ubuntu.com trusty-updates/restricted Translation-en_IN
Ign http://in.archive.ubuntu.com trusty-updates/universe Translation-en_IN
Ign http://in.archive.ubuntu.com trusty-backports/main Translation-en_IN
Ign http://in.archive.ubuntu.com trusty-backports/multiverse Translation-en_IN
Ign http://in.archive.ubuntu.com trusty-backports/restricted Translation-en_IN
Ign http://in.archive.ubuntu.com trusty-backports/universe Translation-en_IN
E: dpkg was interrupted, you must manually run 'sudo dpkg --configure -a' to correct the problem. 

and then according to propted error when i run

$ sudo dpkg --configure -a
dpkg: error: parsing file '/var/lib/dpkg/updates/0009' near line 0:
 newline in field name `#padding'

what how can i get out of the error. i tried this link

share|improve this question

2 Answers 2

up vote 2 down vote accepted

You referred a wrong link. Try the below commands on terminal to remove all the files inside /var/lib/dpkg/updates directory ,

cd /var/lib/dpkg/updates
sudo rm *

And then run the below command to get newer ones,

sudo apt-get update
share|improve this answer
    
it works fine for me . –  user284303 Jun 15 at 13:33

It works for me! I was trying to install the wireless driver when this error came. Had to delete the files and also the lock files.

sudo rm /var/lib/apt/lists/lock
sudo rm /var/cache/apt/archives/lock
cd /var/lib/dpkg/updates
sudo rm *
sudo apt-get update

and then you can run your apt-get install to whatever package you want to install

share|improve this answer
    
Not necessarily a good idea without extra precautions. –  0xC0000022L Jul 19 at 5:59

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.