Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm new to Ubuntu and Ruby and I have a problem, which seems to be strange. I needed to install Ubuntu because of problems with Ruby on Windows.

I've installed Ruby, v. 1.9.3 (the same as I had on Windows). When I launched bundle install, I got this error message:

Installing nokogiri (1.6.0) /usr/lib/ruby/vendor_ruby/1.8/rubygems/installer.rb:388:in ensure_required_ruby_version_met': nokogiri requires Ruby version >= 1.9.2. (Gem::InstallError)
  • But I have version >= 1.9.2.

    Ruby -v returns me ruby 1.8.7. Strange, I installed 1.9.3.

  • When I tried rvm install 1.9.3, the message was Already installed ruby-1.9.3.-p547.

    Which ruby returns me /usr/bin/ruby - because there is only one Ruby version.

I used this tutorial, just write 1.9.3 instead of 2.1.0.

Projects are made in Ruby 1.9.3, there should be any problems when using newer one, it's the real reason why I tried to install this elder ruby version.

Any idea what does this version mess mean?

share|improve this question
up vote 1 down vote accepted

This matters how did you installed the software manually or by apt-get command as you are with 12.04 you will not get the versions that are made after the release of 12.04 directly , I mean if you do a

sudo apt-get install

definetly you will get the version on the universe of your version(older at the time of release of 12.04).

If you need new version download the new pacakge from the website and install it manually...

or you can download a package from here and unpack a tar ball and then follow the instructions

share|improve this answer
Second link has helped me. Thanks. – panther Jun 15 '14 at 12:53

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.