I'm new to Ubuntu and Ruby and I have a problem, which seems to be strange. I needed to install Ubuntu because of problems with Ruby on Windows.
I've installed Ruby, v. 1.9.3 (the same as I had on Windows). When I launched
bundle install, I got this error message:
Installing nokogiri (1.6.0) /usr/lib/ruby/vendor_ruby/1.8/rubygems/installer.rb:388:in ensure_required_ruby_version_met': nokogiri requires Ruby version >= 1.9.2. (Gem::InstallError)
But I have
version >= 1.9.2.
Ruby -vreturns me
ruby 1.8.7. Strange, I installed 1.9.3.
When I tried
rvm install 1.9.3, the message was
Already installed ruby-1.9.3.-p547.
Which rubyreturns me
/usr/bin/ruby- because there is only one Ruby version.
I used this tutorial http://ryanbigg.com/2010/12/ubuntu-ruby-rvm-rails-and-you/, just write
1.9.3 instead of
Projects are made in Ruby 1.9.3, there should be any problems when using newer one, it's the real reason why I tried to install this elder ruby version.
Any idea what does this version mess mean?