Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I just installed a fresh Ubuntu 14.04 TLS installation on my Mac using rEFInd since my last installation did not work. When I install Ubuntu, the wireless does not work. But installing the bcm43xx drivers causes my screen to constant flicker.

I think I really have the wrong drivers. This is the result after executing lspci:

ricardo@ubuntu:~$ lspci -vvnn | grep 14e4
03:00.0 Ethernet controller [0200]: Broadcom Corporation Device [14e4:16a3] (rev10)
        Subsystem: Broadcom Corporation Device [14e4:16b4]
03:00.1 SD Host controller [0805]: Broadcom Corporation BCM57765/57785 SDXC/MMC Card Reader [14e4:16bc] (rev 10) (prog-if 01)
        Subsystem: Broadcom Corporation Device [14e4:96bc]
04:00.0 Network controller [0280]: Broadcom Corporation BCM4331 802.11a/b/g/n [14e4:4331] (rev 02)

Could somebody advice me in my quest to get my wireless working without my screen to flicker?

EDIT: I did some things since my post. A quick coverage:

  • I followed the guide earlier in my post resulting in a working wireless but with flickering screen.

Then I did

  • Opening Additional Drivers and installed the latest (NVIDIA GK107M) [650M Mac Edition]
  • Also installed the suggested Broadcom drivers.

It seem to work now, but sometimes I get a panic at boot resulting in rebooting twice before I can re-use Ubuntu. Small issue left apart from the panics: I only can set the resolution 2880 x 1800. Anyway to get smaller resolutions?

share|improve this question
    
Found the same issue here: askubuntu.com/questions/474475/… –  Naveen Jun 14 at 1:33

1 Answer 1

up vote 0 down vote accepted

I doubt the wireless driver is causing your video issue but all you have to do is remove the driver you installed then reboot and install it this way to find out.

sudo apt-get install linux-firmware-nonfree

reboot.

share|improve this answer
    
I removed the nvidia drivers by doing a apt-get remove nvidia*. Then I added the vga tag to my boot options and that seem to work for now. Thank you for the alternative solution. –  user293136 Jun 16 at 11:12

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.