Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a Toshiba L845 and i when i suspend ubuntu it wake up 2 seconds later. Here you are some info.

cat /proc/cmdline

BOOT_IMAGE=/boot/vmlinuz-3.13.0-29-generic.efi.signed root=UUID=80498f02-8962-4085-81f7-7e01fbc494fc ro quiet splash intel_pstate=enable vt.handoff=7

lspci -k | grep -iA2 VGA

01:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Thames [Radeon HD 7500M/7600M Series]
Subsystem: Toshiba America Info Systems Radeon HD 7670M
Kernel driver in use: fglrx_pci

cat /var/log/syslog | grep PM:

Jun 12 18:38:58 amrras-pc kernel: [ 8765.969162] PM: Syncing filesystems ... done.
Jun 12 18:38:58 amrras-pc kernel: [ 8766.110230] PM: Preparing system for mem sleep
Jun 12 18:38:58 amrras-pc kernel: [ 8766.113428] PM: Entering mem sleep
Jun 12 18:38:58 amrras-pc kernel: [ 8768.119383] PM: suspend of devices complete after 2009.020 msecs
Jun 12 18:38:58 amrras-pc kernel: [ 8768.119501] PM: late suspend of devices complete after 0.117 msecs
Jun 12 18:38:58 amrras-pc kernel: [ 8768.197198] PM: noirq suspend of devices complete after 77.819 msecs
Jun 12 18:38:58 amrras-pc kernel: [ 8768.197824] PM: Saving platform NVS memory
Jun 12 18:38:58 amrras-pc kernel: [ 8768.823061] PM: Restoring platform NVS memory
Jun 12 18:38:58 amrras-pc kernel: [ 8769.069601] PM: noirq resume of devices complete after 125.436 msecs
Jun 12 18:38:58 amrras-pc kernel: [ 8769.069725] PM: early resume of devices complete after 0.099 msecs
Jun 12 18:38:58 amrras-pc kernel: [ 8771.333504] PM: resume of devices complete after 2267.391 msecs
Jun 12 18:38:58 amrras-pc kernel: [ 8771.333680] PM: Finishing wakeup.
Jun 12 18:40:15 amrras-pc kernel: [ 8839.193188] PM: Syncing filesystems ... done.
Jun 12 18:40:15 amrras-pc kernel: [ 8839.378479] PM: Preparing system for mem sleep
Jun 12 18:40:15 amrras-pc kernel: [ 8839.381667] PM: Entering mem sleep
Jun 12 18:40:15 amrras-pc kernel: [ 8841.444678] PM: suspend of devices complete after 2064.091 msecs
Jun 12 18:40:15 amrras-pc kernel: [ 8841.444833] PM: late suspend of devices complete after 0.152 msecs
Jun 12 18:40:15 amrras-pc kernel: [ 8841.524584] PM: noirq suspend of devices complete after 79.797 msecs
Jun 12 18:40:15 amrras-pc kernel: [ 8841.525148] PM: Saving platform NVS memory
Jun 12 18:40:15 amrras-pc kernel: [ 8842.253549] PM: Restoring platform NVS memory
Jun 12 18:40:15 amrras-pc kernel: [ 8842.501780] PM: noirq resume of devices complete after 127.505 msecs
Jun 12 18:40:15 amrras-pc kernel: [ 8842.501902] PM: early resume of devices complete after 0.097 msecs
Jun 12 18:40:15 amrras-pc kernel: [ 8844.770332] PM: resume of devices complete after 2269.779 msecs
Jun 12 18:40:15 amrras-pc kernel: [ 8844.770548] PM: Finishing wakeup.
Jun 12 18:46:17 amrras-pc kernel: [ 9194.444252] PM: Syncing filesystems ... done.
Jun 12 18:46:17 amrras-pc kernel: [ 9194.616654] PM: Preparing system for mem sleep
Jun 12 18:46:17 amrras-pc kernel: [ 9194.619833] PM: Entering mem sleep
Jun 12 18:46:17 amrras-pc kernel: [ 9196.628265] PM: suspend of devices complete after 2010.496 msecs
Jun 12 18:46:17 amrras-pc kernel: [ 9196.628390] PM: late suspend of devices complete after 0.123 msecs
Jun 12 18:46:17 amrras-pc kernel: [ 9196.706763] PM: noirq suspend of devices complete after 78.457 msecs
Jun 12 18:46:17 amrras-pc kernel: [ 9196.707303] PM: Saving platform NVS memory
Jun 12 18:46:17 amrras-pc kernel: [ 9197.435387] PM: Restoring platform NVS memory
Jun 12 18:46:17 amrras-pc kernel: [ 9197.683504] PM: noirq resume of devices complete after 127.185 msecs
Jun 12 18:46:17 amrras-pc kernel: [ 9197.683623] PM: early resume of devices complete after 0.096 msecs
Jun 12 18:46:17 amrras-pc kernel: [ 9199.950284] PM: resume of devices complete after 2269.140 msecs
Jun 12 18:46:17 amrras-pc kernel: [ 9199.950520] PM: Finishing wakeup.

and last:

pastebinit /var/log/pm-suspend.log Link

I found this behavior too:

In AC mode, if i disable Bluetooth the system suspends ok (i tried several times) In Battery mode, it works always ok.

I really do not understand what is going on.

PD: Sorry for my english

Thanks


update!!!!!!!!!!!!!!!!!!!!!!! Well, it seems that everything is random. Then another thing i did was:

I realized that acpitool can change devices to not wake up from suspend (according to what I read)

Before

   Device   S-state   Status   Sysfs node
  ---------------------------------------
  1. P0P1     S4    *disabled
  2. GLAN     S0    *disabled
  3. EHC1     S3    *enabled   pci:0000:00:1d.0
  4. EHC2     S3    *enabled   pci:0000:00:1a.0
  5. XHC      S3    *enabled   pci:0000:00:14.0
  6. HDEF     S0    *disabled  pci:0000:00:1b.0
  7. RP01     S4    *disabled  pci:0000:00:1c.0
  8. RP02     S4    *disabled
  9. PXSX     S4    *disabled
  10. FRES    S0    *disabled
  11. RP03    S0    *disabled  pci:0000:00:1c.2
  12. PXSX    S4    *disabled  pci:0000:08:00.0
  13. RP04    S4    *disabled  pci:0000:00:1c.3
  14. PXSX    S4    *enabled   pci:0000:09:00.0
  15. ATHE    S4    *disabled
  16. RP05    S4    *disabled
  17. PXSX    S4    *disabled
  18. RP06    S4    *disabled
  19. PXSX    S4    *disabled
  20. RP07    S4    *disabled
  21. PXSX    S4    *disabled
  22. RP08    S4    *disabled
  23. PXSX    S4    *disabled
  24. PEG0    S4    *disabled  pci:0000:00:01.0
  25. PEGP    S4    *disabled
  26. PEG1    S4    *disabled
  27. PEG2    S4    *disabled
  28. PEG3    S4    *disabled
  29. LID     S4    *enabled 

After this command: acpitool -W 5

Using lspic i found that device 3,4,5 was: 00:1d.0 USB controller: Intel Corporation 7 Series/C210 Series Chipset Family USB Enhanced Host Controller #1 (rev 04) 00:1a.0 USB controller: Intel Corporation 7 Series/C210 Series Chipset Family USB Enhanced Host Controller #2 (rev 04) 00:14.0 USB controller: Intel Corporation 7 Series/C210 Series Chipset Family USB xHCI Host Controller (rev 04)

   Device   S-state   Status   Sysfs node
  ---------------------------------------
  1. P0P1     S4    *disabled
  2. GLAN     S0    *disabled
  3. EHC1     S3    *disabled   pci:0000:00:1d.0
  4. EHC2     S3    *disabled   pci:0000:00:1a.0
  5. XHC      S3    *disabled  pci:0000:00:14.0
  6. HDEF     S0    *disabled  pci:0000:00:1b.0
  7. RP01     S4    *disabled  pci:0000:00:1c.0
  8. RP02     S4    *disabled
  9. PXSX     S4    *disabled
  10. FRES    S0    *disabled
  11. RP03    S0    *disabled  pci:0000:00:1c.2
  12. PXSX    S4    *disabled  pci:0000:08:00.0
  13. RP04    S4    *disabled  pci:0000:00:1c.3
  14. PXSX    S4    *enabled   pci:0000:09:00.0
  15. ATHE    S4    *disabled
  16. RP05    S4    *disabled
  17. PXSX    S4    *disabled
  18. RP06    S4    *disabled
  19. PXSX    S4    *disabled
  20. RP07    S4    *disabled
  21. PXSX    S4    *disabled
  22. RP08    S4    *disabled
  23. PXSX    S4    *disabled
  24. PEG0    S4    *disabled  pci:0000:00:01.0
  25. PEGP    S4    *disabled
  26. PEG1    S4    *disabled
  27. PEG2    S4    *disabled
  28. PEG3    S4    *disabled
  29. LID     S4    *enabled 

I do not like this solution but it is what i have for now. I do not know how make this setting permanent because i lost changes after reboot. Any idea??? I'm afraid to have any side effect

Thanks again

Martin

share|improve this question
    
"I do not know how make this setting permanent because i lost changes after reboot. Any idea?" - See How do I make changes to /proc/acpi/wakeup permanent? –  bain Aug 3 at 23:40
1  
This is a bug and you should report it on Launchpad. You will then be asked to try the very latest mainline kernel to verify the bug has not already been fixed. If the bug still exists, you will be asked to follow the instructions at DebuggingKernelSuspend –  bain Aug 5 at 10:19

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.