Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Yesterday I bought myself new wi-fi adapter (ASUS PCE-AC66). It works perfect on Windows 7, but today I tried to use it with fresh installation of Kubuntu 14.04, and it's a complete nightmare. I installed bcmwl-kernel-source, connected to my home network, but connection is not stable, there are 'waves' of connection - at one period of time everything works great with perfect speed but several moments after it seems there is no connection at all. And sometimes it is even written that connection is deactivated. What can be the reason? Please help! Thanks in advance.

nm-tool output:

State: connected (global)

- Device: wlan0  [ASUS] --------------------------------------------------------
  Type:              802.11 WiFi
  Driver:            wl
  State:             connected
  Default:           yes
  HW Address:        60:A4:4C:DB:05:6C

  Capabilities:
    Speed:           39 Mb/s

  Wireless Properties
    WEP Encryption:  yes
    WPA Encryption:  yes
    WPA2 Encryption: yes

  Wireless Access Points (* = current AP)
    998:             Infra, 20:CF:30:88:EC:F2, Freq 2437 MHz, Rate 54 Mb/s, Strength 50 WPA
    ASUS:            Infra, 74:D0:2B:3F:43:3C, Freq 5180 MHz, Rate 54 Mb/s, Strength 24 WPA2
    DIR-615:         Infra, C4:A8:1D:44:33:66, Freq 2422 MHz, Rate 54 Mb/s, Strength 42
    *ASUS:           Infra, 74:D0:2B:3F:43:38, Freq 2412 MHz, Rate 54 Mb/s, Strength 52 WPA2
    beeline-10:      Infra, 2C:AB:25:00:D3:57, Freq 2412 MHz, Rate 54 Mb/s, Strength 45 WPA

  IPv4 Settings:
    Address:         192.168.1.111
    Prefix:          24 (255.255.255.0)
    Gateway:         192.168.1.1

    DNS:             192.168.1.1


- Device: eth0 -----------------------------------------------------------------
  Type:              Wired
  Driver:            e1000e
  State:             unavailable
  Default:           no
  HW Address:        14:DA:E9:09:60:E4

  Capabilities:
    Carrier Detect:  yes

  Wired Properties
    Carrier:         off
share|improve this question
    
Try configuring transmission/reception channels to something different than the default. It may be that they overlap with other wifi networks in the area creating temporary congestion and drop of connection. –  hmayag Jun 12 at 8:37
    
How can I perform that? I have extremely low skills in Linux. –  Kirill Smirnov Jun 12 at 8:45
    
Typically, that's done through the router settings, however, to get a list of frequencies in range of the Ubuntu computer open a terminal and use the command nm-tool. –  mchid Jun 12 at 8:59
    
But as I mentioned in post, everything works fine in Windows 7, so the problem is not in hardware... –  Kirill Smirnov Jun 12 at 9:05
    
Okay, let me explain, "interference mitigation" is not supported with the driver you are using and is with the windows driver. So, by changing to a less congested channel could quite possibly fix your problem but you need to know what channels are being used and are most congested in your area. To do that, you will have open a terminal and type in nm-tool. –  mchid Jun 12 at 9:43

1 Answer 1

up vote 1 down vote accepted

First, to be safe, go into Network Manager or the wireless settings Kubuntu equivalent, and click on edit network.

set your BSSID to 74:D0:2B:3F:43:38 to use the 2.4 GHz frequency

or set the BSSID to 74:D0:2B:3F:43:3C to use the 5 GHz frequency

This will prevent confusion as the computer will only associate with this BSSID and will not attempt to "roam" to another BSSID the channel is congested or something else.

Also, to prevent this, change the channel SSID in the router settings from ASUS to something like ASUS1 and ASUS2 so they aren't the same.

Next,

As you can see, beeline-10 is operating on the same channel as ASUS (2412 MHz) and the signal strength is almost the same as yours as well.

Go into your router settings, probably 192.168.1.1 from a browser, and change the 2.4GHz channel to channel 11 (2.462 GHz or 2462 MHz). This will take you far from your neighbor's frequency.

If you are in the United States, you may benefit from the use of the 5 GHz band but only if you have it set to channel 161 (5805 MHz or 5.805 GHz) because of tx and rx regulatory domain restrictions. Seen here,

country US: (2402 - 2472 @ 40), (3, 27) (5170 - 5250 @ 40), (3, 17) (5250 - 5330 @ 40), (3, 20), DFS (5490 - 5600 @ 40), (3, 20), DFS (5650 - 5710 @ 40), (3, 20), DFS (5735 - 5835 @ 40), (3, 30) (57240 - 63720 @ 2160), (N/A, 40)

While you are at it, switch the channel to 40MHz width instead of auto or 20MHz (default) and go for wireless "n only" instead of "b/g/n", "a", or "auto" if you can unless there are other devices that depend on b/g and 20MHz like an older iphone or ipod etc. This should allow up to 150-300Mb/s instead of 52 or less.

Finally,

To check the regulatory domain settings of your Ubuntu computer, use the following command:

sudo iw reg get

If your output looks like this

country 00:
(2402 - 2472 @ 40), (3, 20)
(2457 - 2482 @ 40), (3, 20), PASSIVE-SCAN, NO-IBSS
(2474 - 2494 @ 20), (3, 20), NO-OFDM, PASSIVE-SCAN, NO-IBSS
(5170 - 5250 @ 40), (3, 20), PASSIVE-SCAN, NO-IBSS
(5735 - 5835 @ 40), (3, 20), PASSIVE-SCAN, NO-IBSS

You need to change it to the correct country (00 is world domain imposing any and all wireless restrictions).

Warning: setting this to the wrong country is illegal; See `/usr/share/zoneinfo/zone.tab' for a table of timezone descriptions containing ISO/IEC 3166-1 alpha2 country codes. To do this, use the following command for the United States for example.

First, make a backup of the file.

sudo cp /etc/network/if-pre-up.d/wireless-tools /etc/network/if-pre-up.d/wireless-tools-copy

Then

echo 'iw reg set US' | sudo tee -a /etc/network/if-pre-up.d/wireless-tools 

next, set the CRDA file

sudo nano /etc/default/crda

Change the line from REGDOMAIN= to REGDOMAIN=US and use, CTRL + o, press enter to overwrite and save changes, and CTRL + x to exit.

overlaping channels

http://en.wikipedia.org/wiki/List_of_WLAN_channels

share|improve this answer
    
Thanks for detailed answer! I'll upvote it as soon as I get 15 points. I understand that your answer is correct, but the problem is that even if I set proper BSSID in network manager, it still tries to connect to another BSSID (I even restarted the computer to be sure that changes were applied). So I still don't know what to perform to prevent switching frequencies :( –  Kirill Smirnov Jun 13 at 7:39
    
Assign two separate names for the networks in the router settings, i.e. ASUS1 and ASUS2. Then, clear the existing networks from Network Manager use sudo dolphin "/etc/NetworkManager/system-connections" you will see a file for each network; Network Manager stores connection profiles here. Delete all networks you do not intend to use in the future so they do not automatically connect again in the future. If you want to start from scratch, delete all the networks and set up only one connection all over again to one BSSID. Use sudo -K if you are done using sudo. –  mchid Jun 15 at 2:29

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.