Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am having a problem where when I try to run say GParted, when I am prompted for a password, it says "Incorrect Password"

But when I enter the same password using terminal sudo gparted for example, it works. Why is that?

UPDATE

I noticed that theres a difference between using sudo and gksu. The later will fail with incorrect password ...

share|improve this question
    
Do you have a different keyboard layout in the terminal? Test by typing in a text editor both in terminal and in gui. –  con-f-use Jun 11 '11 at 13:54
    
Are you using LDAP, Active Directory, Samba, bluetooth, smart card, or any other password authentication methods, or is this simply a standalone computer? –  ihashacks Aug 17 '11 at 16:58
add comment

2 Answers

up vote 6 down vote accepted
+50

Have you tried gksudo? I've actually never seen gksu before.

From https://lists.ubuntu.com/archives/ubuntu-studio-users/2007-September/000472.html:

gksu is a frontend to su, and gksudo is a frontend to sudo.

So if sudo is working properly for you, gksudo and not gksu is the graphical extension of sudo when you need to gain administrative privileges without using the terminal.

share|improve this answer
3  
Actually, gksu is a frontend for both gksu and gksudo (see manpages.ubuntu.com/manpages/natty/en/man1/gksu.1.html, Description, paragraph 3). While there is nothing wrong with using gksudo, gksu is the standard way to run graphical programs as root on Ubuntu (even though sudo, and not su, is used), and many graphical programs install menu items that use gksu. In a properly working Ubuntu system, gksu is set is sudo rather than su mode. Thus, desgua's post about setting the authentication mode to "sudo" in gksu-properties is really the correct answer to this question. –  Eliah Kagan Aug 17 '11 at 17:46
add comment

Open gksu-properties (Alt + F2 and type gksu-properties).
Then make sure the Authentication mode is set for "sudo".

enter image description here

Reference: 1.

share|improve this answer
    
Indeed, gksu is a frontend to both sudo and su, and when a sudo-using OS like Ubuntu has working gksudo and broken gksu, it is almost always because the authentication mode is incorrectly set to su. Since sudo-mode=true in a correctly configured Ubuntu system, this problem is at least sometimes and perhaps always due to a bug. If this has always happened since installation and the system was created from a command-line only system, then this is bugs.launchpad.net/ubuntu/+source/gksu/+bug/685349 (you can use the green "This bug affects..." link to indicate it affects you). –  Eliah Kagan Aug 17 '11 at 17:52
    
Thanks for the added information and support. –  desgua Aug 17 '11 at 18:03
    
Learning something new every day. Thanks for the info! –  Dang Khoa Aug 17 '11 at 18:59
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.