Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Recently I found that window borders keep disappearing intermittently in Unity! Especially when either Google Chrome or Mozilla Thunderbird are running.

Is there a way out?

share|improve this question
    
I have the same issue and a two more: My indicator applets cease to be clickable at random time intervals and sometimes the part, where the unity launcher is hidden is cut off. –  con-f-use Jun 11 '11 at 11:21

3 Answers 3

Usually restarting unity helps. You can do this by Alt+F2 and then typing:

unity --replace

Note: Don't execute this command in a terminal otherwise unity will be killed, when the terminal is closed.

This is of course not a fix. Just a way to undo the error once it has occurred. I suppose these bugs (and the ones posted in my comments to your question) will be fixed with future updates. There are many bug-reports on launchpad concerning these.

You could also try ans install CompizConfig Settings Manager Install compizconfig-settings-manager / sudo apt-get install compizconfig-settings-manager and play with the setting there. It might or might not help - depending on who you ask.

share|improve this answer
1  
Ok! Thanks for the prompt reply, it solved my problem, though I wish there was a more permanent solution for this bugging issue. –  adityavpratap Jun 11 '11 at 11:34
2  
As I said, there will be in the future versions. Unity isn't mature yet. If you liked the answer: How about an upvote and/or marking it accepted? –  con-f-use Jun 11 '11 at 11:40

Have you enabled keeping minimized windows thumbnails under "workarounds" in ccsm? If so, disable it -- it messed up my unity bad.

share|improve this answer
    
I checked the settings in ccsm. "keeping minimized windows thumbnails" is not enabled. So I guess I'll have to do with "unity --replace" till the bug gets fixed. –  adityavpratap Jun 13 '11 at 13:49

I fixed this issue permanently by entering CompizConfig Settings Manager (CCSM) —if you don't have it do sudo apt-get install compizconfig-settings-manager—, going into the Window Decorations options, and changing the Command setting to compiz-decorator.

Backing out of this menu, then unchecking Window Decoration, allowing the desktop to reload, then checking Window Decoration and exiting out of CCSM.

After doing this, I can no longer reproduce the issue.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.