Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This question already has an answer here:

10th of June i've made an update and now I'm no more able to login. Unfortunately I don't know wat was included in this update. My PC looks like logging in, but, after a few seconds, it comes back to the login screen and ask me again and again the password (or to select another account).

share|improve this question

marked as duplicate by karel, Warren Hill, Eric Carvalho, bain, Sneetsher Jul 21 at 16:21

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

1 Answer 1

Try this for me:

When you boot up, press Ctrl+Alt+F1 and attempt to log on using your local account, and see if that works.

If it does work, it may be that your password is somehow out of sync with the window manager that you're using, as seems to be the case in this question. Try doing the following, if you can log in:

sudo -i
[Enter your password]
passwd usr

Where usr is your username. Then, it should ask you for a new password, enter it in. Once you've done that type

reboot

And try to log back in once it's back to the screen.

If this doesn't work, please provide us this information:

  1. Version of ubuntu (and flavor (e.g. xubuntu, kubuntu, etc))
  2. What window manager you're using, if not the default for your flavor
  3. If you're using compiz
share|improve this answer
    
I'll do that today afternoon (I have no access to my PC right now), but I have to note that I also have an account for my daughter with no password. Same behaviour. Seems to login and after few seconds it comes back to the login screen. –  Dumitru Cristian Jun 12 at 5:01
    
The result of executing your code didn't help. I uninstalled and reinstall lightdm, tried also with gdm, same situation. I have Ubuntu 14.04 TT, default window manager, I've uninstalled compiz. –  Dumitru Cristian Jun 13 at 6:08
    
Try following the instructions here and see if it helps –  musher Jun 13 at 13:38
    
I tried, no result. Reinstalled 14.04 to solve. –  Dumitru Cristian Jun 14 at 8:50

Not the answer you're looking for? Browse other questions tagged or ask your own question.