Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I tried adding tomboy in System -> Preferences -> Startup Applications, but this causes the "Search All Notes" window to appear every time I log in. I just want it to run in the notification area so that I can use it later via hotkeys or its notification area icon popup menu.

share|improve this question

2 Answers 2

up vote 11 down vote accepted

There is an undocumented option --icon that makes tomboy start without showing a window. It HAD a bug (bug #566421), which has now been resolved.

Also, you can use the tomboy applet: Right click on the panel, choose “Add to Panel” and select “Tomboy Notes“. The panel applet looks similar to the notification area icon and provides the same functionality (hotkeys and popup menu).

share|improve this answer
1  
Thanks, tomboy --icon works for me. –  ændrük Sep 27 '10 at 21:30
    
Thanks. It works for me too (under Unity) –  tawmas Apr 22 '11 at 15:32
    
Does this also work for the numerous notes that will automatically open (I guess because they were open when shutting down)? I'd like to stop tomboy from opening any note when loading. –  Redsandro Feb 4 '13 at 2:49
    
tomboy --icon works fine in ubuntu 13.04 using Startup Application Preferences. bug #566421 does not apply, so please remove the reference to this bug. –  Bernard Decock Aug 30 '13 at 9:31

The search menu will appear if the panel is not ready. Use a script like #!/bin/sh && /bin/sleep 18 && /usr/bin/tomboy instead of plain tomboy

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.