Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've installed Ubuntu 12.04 on an external USB3.0 drive. I selected sdb (the usb stick) as grub point and created a new ext4 partition as root on sdb1. Everything went very well and I could either boot Windows 8.1 or Ubuntu (of course only if the USB stick was plugged). I noticed that on my bios EFI menu I had 3 records:

  • Windows boot Manager
  • Ubuntu
  • ubuntu

Ubuntu is the /EFI/UBUNTU/GRUBX64.EFI whereas ubuntu is /EFI/UBUNTU/SHIMX64.EFI ( I guess because I had the security bot enabled and I needed the SHIMX64 as "bridge").

Here comes the problem.. I've formatted the pen drive and I now want to remove the two ubuntu records. I don't want any trace of them into my system. I tried using efibootmgr

sudo efibootmgr -b #record -B

but I was only able to remove the SHIMX64 (ubuntu) whereas the other (Ubuntu) is still there and re-appears everytime I reboot the system. I've also tried both EasyUEFI for Windows and the tool inside the bios (Dell M3800) but it is the same ( I can delete it and it appears again).

Description:Ubuntu
GPT partition GUID:{384AAD4C-D1FD-46CB-844B-F665289C1CBF}
Partition number:1
Partition starting sector:2048
Partition ending sector:1026047
File path:\EFI\UBUNTU\GRUBX64.EFI

What should I do? ( please consider that I am quite new with Ubuntu) My problem is similar to this one but I cannot fix it.

Many thanks in advance.

share|improve this question

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.