Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've followed the tutorial on this site: http://forums.bit-tech.net/showthread.php?t=132029

I have a DD-WRT router with Micro-FW that does not have a built-in VPN server. I have port forwarded the port 1723 TCP to my Ubuntu box. My DD-WRT router's DHCP ranges from 192.168.1.100 - 199.

The problem is that I can connect to my VPN server and access all the network shares and computers but I cannot access the internet. I am not too sure why this is happening. Please let me know if you want to see any of the files.

I have set the /etc/pptpd.conf:

localip 192.168.1.102
remoteip 192.168.1.190-198

Do I need to manage my DHCP on my Ubuntu box as well or is that okay? I am a beginner, any help is appreciated!

share|improve this question
    
I have the exact same problem, please let me know if you've found a solution! :) Though, Ive allready added netmask "255.255.255.0" via "/etc/ppp/options"... But I can't seem to find a way to pass the gateway to the client. –  user22280 Jul 26 '11 at 23:11
    
Which Ubuntu version? What router hardware (brand, model), and release of DD-WRT ? –  david6 Dec 12 '11 at 5:41

1 Answer 1

Edit the options file with sudo nano /etc/ppp/pptpd-options

uncomment the line that reads #ms-dns 10.0.0.1 by removing the #

Replace the address with whatever DNS server you wish to use Save and exit

Restart the pptp service with sudo /etc/init.d/pptpd restart

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.