Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

My laptop was working perfectly yesterday, and now today I can't log in.

At first, I was only getting a black screen. However, after following instructions in some questions here on AskUbuntu, I first reinstalled lightdm, and then I had to change the ownership of the file ~/.Xauthority to be my user name. Now, I get the log in GUI screen.

However, once I enter my username, it flickers and then comes back to the login GUI. It does not matter if I use Gnome, Unity, or Gnome-Flashback.

I don't know why lightdm needed to be reconfigured, or how ~/.Xauthority got changed, but in any case, what is still standing in my way, preventing me from logging in?

Update: I have tried deleting the .Xauthority file, and the .profile files in my home directory. It has not changed anything.

Logging in as guest also fails to work.

The following commands did not work:

mv ~/.config ~/.config.BAK
mv ~/.cache ~/.cache.BAK

Inside .xsession-errors in my home directory, it says:

Gdk-CRITICAL: gdk_x11_display_get_xdisplay: assertion 'GDK_IS_DISPLAY (display)' failed
share|improve this question
Have you tried deleting the .Xauthority file then rebooting? – Cornelius Jun 11 '14 at 7:25
@Cornelius, thank you for responding. Unfortunately, deleting .Xauthority did not fix the problem. – Questioner Jun 11 '14 at 7:51
how did you know that the repository updated those 4 package ?? I ve the same problem but it triggered when i installed virtualbox form a .deb – dSx Jul 12 '15 at 15:19
up vote 5 down vote accepted

I fixed my issue. I had this repository

deb trusty main

in my list. That repository yesterday updated these 4 packages to a custom version (based on GNOME 3.12):

  • ubuntu-session
  • gnome-session-common
  • gnome-session-bin
  • gnome-session

I downgraded these packages to the version 3.9.90-0ubuntu12 and after a sudo service lightdm restart all is working, up and running.

To downgrade from command line:

sudo apt-get install --reinstall gnome-session-bin=3.9.90-0ubuntu12
sudo apt-get install --reinstall gnome-session-common=3.9.90-0ubuntu12
sudo apt-get install --reinstall gnome-session=3.9.90-0ubuntu12
sudo apt-get install --reinstall ubuntu-session=3.9.90-0ubuntu12
share|improve this answer
Sounds good. Can you be more descriptive in how exactly you did that? How does one downgrade these packages from the commandline? – Questioner Jun 11 '14 at 9:45
I added the command on the answer :) – oskarnrk Jun 11 '14 at 9:51
Great work! I have my laptop back. Also, welcome to AskUbuntu! :) – Questioner Jun 11 '14 at 10:02
Thank you, Dave ;) – oskarnrk Jun 11 '14 at 10:07
What's special about this PPA? And why should I trust it? – Cerin Jan 3 '15 at 3:01

I my case I replace lightdm to GDM Worked for me

sudo apt-get install gdm
sudo dpkg-reconfigure gdm

Select the display manager GDM

share|improve this answer

I had this problem too after updating. I had to reinstall the display driver to get it to work. The computer that had this problem has an nVidia card running nVidia's driver.

share|improve this answer

protected by Pilot6 Oct 15 '15 at 14:57

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.