Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm new to Ubuntu and I can't get the right resolution: The only one I can choose in "monitor settings" (I'm running Lubuntu 14.04 because the laptop is too slow for Ubuntu) is 640 x 480 (with a refresh rate of 73 Hz). On Windows XP I had 1280 x 800 (at 60 Hz) and - that's the strange part - when I was booting the test version with an USB stick I could choose between 640 x 480 and 1024 x768! Does anyone have an idea what might have happened?

The laptop is an Esprimo Mobile v5535 with a sis 672 graphic card. I've already found out that this graphic card makes some trouble and that there is no supported driver (I've already checked the "additional drivers").

What I have tried out so far:

Using xrandr (cvt --> newmode --> addmode --> output), following i.e. this link. I do create a new mode but the resolution doesn't change when I try to apply it. Here is what xrandr says:

xrandr: Failed to get size of gamma for output default
Screen 0: minimum 640 x 480, current 640 x 480, maximum 640 x 480
default connected 640x480+0+0 0mm x 0mm
   640x480        73.0*

As it also says "maximum 640 x 480", I tried to increase the virtual screen following this (at one point - I don't remember when - I got this "screen cannot be larger than 640 x 480"-message). This only led to a black screen and I had to reactivate the backup of xorg.conf.

Since at the beginning I didn't have any xorg.conf-file, I created a new file which I simply named xorg.conf containing the following:

Section "Device"
    Identifier    "Configured Video Device"
EndSection

Section "Monitor"
    Identifier    "Configured Monitor"
    HorizSync       30.0-62.0
    VertRefresh     50.0-70.0
EndSection

Section "Screen"
    Identifier    "Default Screen"
    Monitor        "Configured Monitor"
    Device        "Configured Video Device"
    DefaultDepth    24
    SubSection "Display"
        Depth    24
        Modes     "1024x768" "800x600"
    EndSubSection
EndSection

I then moved it to /etc/X11 because I read this in a website (to which I don't remember the link). Don't know whether this is how to do it (Xorg --configure didn't work --> I only got the message that this option doesn't exist).

I really don't know how to manage the problem and I would be glad if someone could help me. And I find it very irritating that everything was ok in the test version!

EDIT: I solved the problem by installing Linux Mint 13 (!) instead of Ubuntu and it works with my graphic card. I still get only 1024 x 768 but it's ok for what I have to do.

share|improve this question

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.