Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am posting this again because I have changed to VMWare Player and I discovered something new.

I am running Ubuntu 12.04 LTS (Guest) in VMWare Player 6.0.2 on Windows 7 64-bit Host. I have VMWare Tools installed properly.
I am running MATE but the problem persists when I change (to and from) xfce, gnome, mate a-- and back again I had been using this for a couple of years without any graphics issues. After an Ubuntu update (typical) -- my video is corrupt and will not refresh correctly.

My desktop icons are "mirrored" and when I open a terminal window (for instance) -- sometimes -- the window appears multiple times.
Of course, only one is the real image. It seems to be a refresh problem.
When I move an active window around the screen the "older" images "erase" and my icons (for instance) are in the correct location.
For instance, I can move the terminal around a pretty corrupted window and the screen behind it is repainted correctly.

NEW:

Next, I got the idea to try and Remote Desktop in to the Ubuntu 12.04 LTS Guest OS from my Windows 7 64-bit Host.

Once working, and connected via Win RDC -- using MATE as default in my /etc/xrdp/startws.sh -- my video is not corrupted and works fine (as in the past).

Any ideas about what is going on ? or how to fix this ?

share|improve this question
    
Since remote desktop works fine, the problem is either the VMware GPU driver in Ubuntu, or VMware, or Windows GPU driver. You could try Ubuntu 14.04 and if the bug still occurs report it to VMware. Or use VirtualBox. –  bain Jun 10 at 20:51
    
You could also try disabling the 3D graphics checkbox in VM Settings > Display. –  bain Jun 10 at 20:54
    
add comment

1 Answer 1

I had the same "mirroring" problem after updating my vmware 64 bit Ubuntu. The previous version was fine. I fixed the problem by copying

/lib/modules/3.2.0-30-generic/kernel/drivers/gpu/drm/vmwgfx/vmwgfx.ko

to

/lib/modules/3.2.0-65-generic/kernel/drivers/gpu/drm/vmwgfx/vmwgfx.ko

After renaming the original driver under 3.2.0-65. I don't know at what version the driver broke since "30" was the previous version that I had. 32 bit Ubuntu exhibited the same problem after updating. Downgrading the driver as above fixed it as well.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.