Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Upgrading from Ubuntu 13.10 to Ubuntu 14.04 has resulted in a system that is not bootable.

The system consists of two disks: One with Windows 8 (/dev/sdaX) and one with Ubuntu 14.04 (/dev/sdbX). I was previously booting using an EFI partition /dev/sda2, but the Ubuntu upgrade installer has rendered this inoperative: it fails to a gparted fallback screen. /dev/sdb was originally a legacy MBR/BIOS-based system. I have attempted to create an EFI partition on /dev/sdb1, but I am not sure if I did it right. Boot-repair fails to fix either EFI partition.

Both Windows and Ubuntu are bootable with the assistance of super grub disk, but that is only the way I can get either system to boot.

Secure boot is not enabled.

Boot information is here: http://paste.ubuntu.com/7622020/

Do you have any recommendations for me? This looks like the bug given in https://bugs.launchpad.net/ubuntu/+source/grub2/+bug/1289977 , but there is no clear resolution available.

share|improve this question

2 Answers 2

up vote 1 down vote accepted

I recommend you try my rEFInd boot manager. (It looks like you may have tried it at some point in the past but I see no evidence that it's currently installed.) Use the CD-R or USB flash drive version from the rEFInd downloads page for testing. If that doesn't work, you'll have done no more harm and you can move on to some other approach; but if it does work to boot both Linux and Windows, you can install the Debian package (either single-shot using the package from the downloads page or by using the PPA referenced at the bottom of the downloads page).

share|improve this answer
    
Would you recommend installing it on my sda or sdb? –  Colin Jun 10 at 12:59
    
It shouldn't matter; use whichever one is currently mounted as /boot/efi. –  Rod Smith Jun 11 at 0:15

The rEFInd bootloader did the trick. My system's EFI firmware does not remember the symbolic "refind" name, however: it only remembers devices, and it will always try and boot the device default. To get around this, I had to install refind from the install.sh script with

./install.sh --usedefault /dev/sdXX

Read the install guide before using this option. If you use the wrong /dev entry, you could wipe out all your data.

It might be useful if the PPA version of refind had some dpkg-reconfigure style option to that extent.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.