Sign up ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

I know it seems like a duplicate question, but I in fact couldn't find any topics, where people have the exact problem as me. I am desperately trying to upgrade my Ubuntu, but many searches and trials haven't helped yet. So, I really hope you guys can help me upgrade my old ubuntu :)

I will just describe, what I tried so far.

First of all: lsb_release -a

    LSB Version:    core-2.0-amd64:core-2.0-noarch:core-3.0-amd64:core-3.0-noarch:core-3.1-amd64:core-3.1-noarch:core-3.2-amd64:core-3.2-noarch:core-4.0-amd64:core-4.0-noarch:cxx-3.0-amd64:cxx-3.0-noarch:cxx-3.1-amd64:cxx-3.1-noarch:cxx-3.2-amd64:cxx-3.2-noarch:cxx-4.0-amd64:cxx-4.0-noarch:desktop-3.1-amd64:desktop-3.1-noarch:desktop-3.2-amd64:desktop-3.2-noarch:desktop-4.0-amd64:desktop-4.0-noarch:graphics-2.0-amd64:graphics-2.0-noarch:graphics-3.0-amd64:graphics-3.0-noarch:graphics-3.1-amd64:graphics-3.1-noarch:graphics-3.2-amd64:graphics-3.2-noarch:graphics-4.0-amd64:graphics-4.0-noarch:printing-3.2-amd64:printing-3.2-noarch:printing-4.0-amd64:printing-4.0-noarch:qt4-3.1-amd64:qt4-3.1-noarch
    Distributor ID: Ubuntu
    Description:    Ubuntu 13.04
    Release:        13.04
    Codename:       raring

Then I followed the steps from the instructions from ubuntuusers:

sudo apt-get update

Hit raring Release.gpg
Hit raring-updates Release.gpg
Hit raring-backports Release.gpg
Hit raring-security Release.gpg
Hit raring Release
Hit raring-updates Release
Hit raring-backports Release
Hit raring-security Release
Hit raring/main Sources
Hit raring/restricted Sources
Hit raring/universe Sources
Hit raring/multiverse Sources
Hit raring/main amd64 Packages
Hit raring/restricted amd64 Packages
Hit raring/universe amd64 Packages
Hit raring/multiverse amd64 Packages
Hit raring/main i386 Packages
Hit raring/restricted i386 Packages
Hit raring/universe i386 Packages
Hit raring/multiverse i386 Packages
Hit raring/main Translation-en
Hit raring/main Translation-en_GB
Hit raring/main Translation-de
Hit raring/main Translation-ru
Hit raring/multiverse Translation-en
Hit raring/multiverse Translation-en_GB
Hit raring/multiverse Translation-de
Hit raring/multiverse Translation-ru
Hit raring/restricted Translation-en
Hit raring/restricted Translation-en_GB
Hit raring/restricted Translation-de
Hit raring/restricted Translation-ru
Hit raring/universe Translation-en
Hit raring/universe Translation-en_GB
Hit raring/universe Translation-de
Hit raring/universe Translation-ru
Hit raring-updates/main Sources
Hit raring-updates/restricted Sources
Hit raring-updates/universe Sources
Hit raring-updates/multiverse Sources
Hit raring-updates/main amd64 Packages
Hit raring-updates/restricted amd64 Packages
Hit raring-updates/universe amd64 Packages
Hit raring-updates/multiverse amd64 Packages
Hit raring-updates/main i386 Packages
Hit raring-updates/restricted i386 Packages
Hit raring-updates/universe i386 Packages
Hit raring-updates/multiverse i386 Packages
Hit raring-updates/main Translation-en
Hit raring-updates/multiverse Translation-en
Hit raring-updates/restricted Translation-en
Hit raring-updates/universe Translation-en
Hit raring-backports/main Sources
Hit raring-backports/restricted Sources
Hit raring-backports/universe Sources
Hit raring-backports/multiverse Sources
Hit raring-backports/main amd64 Packages
Hit raring-backports/restricted amd64 Packages
Hit raring-backports/universe amd64 Packages
Hit raring-backports/multiverse amd64 Packages
Hit raring-backports/main i386 Packages
Hit raring-backports/restricted i386 Packages
Hit raring-backports/universe i386 Packages
Hit raring-backports/multiverse i386 Packages
Hit raring-backports/main Translation-en
Hit raring-backports/multiverse Translation-en
Hit raring-backports/restricted Translation-en
Hit raring-backports/universe Translation-en
Hit raring-security/main Sources
Hit raring-security/restricted Sources
Hit raring-security/universe Sources
Hit raring-security/multiverse Sources
Hit raring-security/main amd64 Packages
Hit raring-security/restricted amd64 Packages
Hit raring-security/universe amd64 Packages
Hit raring-security/multiverse amd64 Packages
Hit raring-security/main i386 Packages
Hit raring-security/restricted i386 Packages
Hit raring-security/universe i386 Packages
Hit raring-security/multiverse i386 Packages
Hit raring-security/main Translation-en
Hit raring-security/multiverse Translation-en
Hit raring-security/restricted Translation-en
Hit raring-security/universe Translation-en
Ign raring/main Translation-en_US
Ign raring/multiverse Translation-en_US
Ign raring/restricted Translation-en_US
Ign raring/universe Translation-en_US
Ign raring-updates/main Translation-en_US
Ign raring-updates/main Translation-en_GB
Ign raring-updates/main Translation-de
Ign raring-updates/main Translation-ru
Ign raring-updates/multiverse Translation-en_US
Ign raring-updates/multiverse Translation-en_GB
Ign raring-updates/multiverse Translation-de
Ign raring-updates/multiverse Translation-ru
Ign raring-updates/restricted Translation-en_US
Ign raring-updates/restricted Translation-en_GB
Ign raring-updates/restricted Translation-de
Ign raring-updates/restricted Translation-ru
Ign raring-updates/universe Translation-en_US
Ign raring-updates/universe Translation-en_GB
Ign raring-updates/universe Translation-de
Ign raring-updates/universe Translation-ru
Ign raring-backports/main Translation-en_US
Ign raring-backports/main Translation-en_GB
Ign raring-backports/main Translation-de
Ign raring-backports/main Translation-ru
Ign raring-backports/multiverse Translation-en_US
Ign raring-backports/multiverse Translation-en_GB
Ign raring-backports/multiverse Translation-de
Ign raring-backports/multiverse Translation-ru
Ign raring-backports/restricted Translation-en_US
Ign raring-backports/restricted Translation-en_GB
Ign raring-backports/restricted Translation-de
Ign raring-backports/restricted Translation-ru
Ign raring-backports/universe Translation-en_US
Ign raring-backports/universe Translation-en_GB
Ign raring-backports/universe Translation-de
Ign raring-backports/universe Translation-ru
Ign raring-security/main Translation-en_US
Ign raring-security/main Translation-en_GB
Ign raring-security/main Translation-de
Ign raring-security/main Translation-ru
Ign raring-security/multiverse Translation-en_US
Ign raring-security/multiverse Translation-en_GB
Ign raring-security/multiverse Translation-de
Ign raring-security/multiverse Translation-ru
Ign raring-security/restricted Translation-en_US
Ign raring-security/restricted Translation-en_GB
Ign raring-security/restricted Translation-de
Ign raring-security/restricted Translation-ru
Ign raring-security/universe Translation-en_US
Ign raring-security/universe Translation-en_GB
Ign raring-security/universe Translation-de
Ign raring-security/universe Translation-ru
Reading package lists... Done

sudo apt-get dist-upgrade

Reading package lists... Done                                                                                                                                                                                                                                                   
Building dependency tree                                                                                                                                                                                                                                                        
Reading state information... Done                                                                                                                                                                                                                                               
Calculating upgrade... Done                                                                                                                                                                                                                                                     
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.   

Update manager core is installed.

sudo do-release-upgrade (had to delete about 90% of it, because site doesn't allow so many characters)

Hit raring/main Translation-en_GB                            
Hit raring/main Translation-de                               
Hit raring/main Translation-ru                                  

Err saucy-security/restricted Translation-de                 

Err saucy-security/restricted Translation-ru                 

Err saucy-security/universe Translation-en_US                

Err saucy-security/universe Translation-en_GB                

Err saucy-security/universe Translation-de                   

Err saucy-security/universe Translation-ru                   

Ign saucy/main Translation-en_US                             
Ign saucy/multiverse Translation-en_US                       
Ign saucy/restricted Translation-en_US                       
Ign saucy/universe Translation-en_US                         
Ign saucy-updates/main Translation-en_US                     
Ign saucy-updates/multiverse Translation-en_US               
Ign saucy-updates/restricted Translation-en_US               
Ign saucy-updates/universe Translation-en_US                 
Ign saucy-backports/main Translation-en_US                   
Ign saucy-backports/main Translation-en_GB                   
Ign saucy-backports/main Translation-de                      
Ign saucy-backports/main Translation-ru                      
Ign saucy-backports/multiverse Translation-en_US             
Ign saucy-backports/multiverse Translation-en_GB             
Ign saucy-backports/multiverse Translation-de                
Ign saucy-backports/multiverse Translation-ru                
Ign saucy-backports/restricted Translation-en_US             
Ign saucy-backports/restricted Translation-en_GB             
Ign saucy-backports/restricted Translation-de                
Ign saucy-backports/restricted Translation-ru                
Ign saucy-backports/universe Translation-en_US               
Ign saucy-backports/universe Translation-en_GB               
Ign saucy-backports/universe Translation-de                  
Ign saucy-backports/universe Translation-ru                  
Ign saucy-security/main Translation-en_US                    
Ign saucy-security/main Translation-en_GB                    
Ign saucy-security/main Translation-de                       
Ign saucy-security/main Translation-ru                       
Ign saucy-security/multiverse Translation-en_US              
Ign saucy-security/multiverse Translation-en_GB              
Ign saucy-security/multiverse Translation-de                 
Ign saucy-security/multiverse Translation-ru                 
Ign saucy-security/restricted Translation-en_US              
Ign saucy-security/restricted Translation-en_GB              
Ign saucy-security/restricted Translation-de                 
Ign saucy-security/restricted Translation-ru                 
Ign saucy-security/universe Translation-en_US                
Ign saucy-security/universe Translation-en_GB                
Ign saucy-security/universe Translation-de                   
Ign saucy-security/universe Translation-ru                   
Fetched 41.6 MB in 6s (0 B/s)                                                              

Checking package manager
Reading package lists... Done    
Building dependency tree          
Reading state information... Done
Building data structures... Done 

Calculating the changes

Calculating the changes

Could not calculate the upgrade 

An unresolvable problem occurred while calculating the upgrade. 

This can be caused by: 
* Upgrading to a pre-release version of Ubuntu 
* Running the current pre-release version of Ubuntu 
* Unofficial software packages not provided by Ubuntu 

If none of this applies, then please report this bug using the 
command 'ubuntu-bug ubuntu-release-upgrader-core' in a terminal. 

Restoring original system state

Reading package lists... Done    
Building dependency tree          
Reading state information... Done
Building data structures... Done 

I also tried updating through software center.

The order of steps, and their effects:

  • Click on Software Center.
  • Software Updater Window appears.
  • Windows says "Checking for updates".
  • Windows says "Software updates are no longer provided for Ubuntu 13.04".
  • I click on "Upgrade"-Button.
  • I am asked to enter my password - do so.
  • The windows just disappear and nothing happens.

Please let me know, if more info is needed, to solve the problem.

Thank you in advance!

share|improve this question

2 Answers 2

up vote 0 down vote accepted

I might be wrong, but I think Ubuntu 13.xx has gone the way of the dinosaurs: They are supporting 12.04 and 14.04, both LTS (long term support) versions.

share|improve this answer
What does that mean for me? Is it no longer able to upgrade from 13.04 to 13.10? – Fred Funks Jun 9 '14 at 22:42
You might be able to download a suitable ISO for boot/install from USB at this location but you should be aware that updates of problematic programs probably will not be forthcoming from Ubuntu. – Charles Green Jun 9 '14 at 22:47
@FredFunks You need to skip from 13.04 to 14.04, using a live install disk – eyoung100 Jun 9 '14 at 22:48
Thank you a lot for your answers. Can you tell me, what I should be aware of, before installing 14.04 from a live disk? Especially I'm concerned about the ATI-Drivers. It probably will result in a black screen after an update, wouldn't it? – Fred Funks Jun 9 '14 at 22:56
I have trouble with the AMD drivers and am unable to get them to compile. On the other hand, the open source drivers are working OK, so I'm not too worried. I suspect that the same is true of the ATI drivers. Make a full backup of anything you want to save (include the .thunderbird and other hidden directories). Ubuntu recommends a fresh install rather than an upgrade, and from what I read above you may have an unsupported software package which may stop the upgrade processes. – Charles Green Jun 9 '14 at 23:00

I am currently updating my version now from 12.04 to 13.04 and 13.10 and so far i only came across one problem and is when I try to boot and shut down, it paused at the loading page. but other than that. i did exactly what you did and didn't have any other problems.

did you try using a cd installment?

share|improve this answer
Hello Phamtasm. I didn't try a cd-installment yet. Is there a way, to do it from my current ubuntu, or do I have to boot from the cd? – Fred Funks Jun 9 '14 at 23:12
yes there is a way. I have my brother make a copy of 13.04 and when you install it like you would with any os. there is an option that you can choice from. the first one will say install 13.04 alongside with 13.10, the second one would say erase 13.04 and install 13.10 and i forget what did the third one was. but i can't promise you if your data will be erase or now. i would recommend backing it up before trying so. – Phamtasm Jun 9 '14 at 23:16
Ok, thank you for the info. I will try installing it from a CD. – Fred Funks Jun 9 '14 at 23:39
best of luck to you. – Phamtasm Jun 10 '14 at 0:02
right now, i am updating my 13.10 and hopeful i will upgrade to version 14.04. – Phamtasm Jun 10 '14 at 0:02

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.